Bug 113077 - NFS client reads are slow
NFS client reads are slow
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2004-01-08 00:32 EST by Davka
Modified: 2015-01-04 17:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-29 15:56:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Davka 2004-01-08 00:32:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1)

Description of problem:
Installed fc1 on my Dell Inspiron 3500 laptop.  I mounted an nfs
partition and copied a file (using cp) from the partition to the 
laptop's local disk.  The copy was very slow, about 4.5 minutes for
~ 20 MB.  I copied the file back to the nfs partition, and it worked
normally.  The laptop has previously run rh9 and freebsd, and nfs
has worked well.  The nfs server is a redhat 8 box and has been running
well for a year.  I tried two net cards in the laptop, a Linksys WPC11
v 2.5 wireless card and a Linksys PCM100 ethernet card.  There was no
noticeable difference in performance between the two cards.  The problem
is the same for the .2115 and .2140 kernels.  nfsstat -rc reports
roughly one retrans for every three nfs calls.  Feel free to e-mail
or call me; I will be happy to perform tests. 
redhat-bugzilla@immersive.com or (505) 737 9111.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install fc1
2. Mount an NFS partition
3. Copy a file from the NFS partition to the local disk

Actual Results:  I waited about 4.5 minutes for a ~ 20 MB to copy

Expected Results:  More like a 20-second wait?

Additional info:
Comment 1 David Lawrence 2004-09-29 15:56:27 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.