Bug 1130854 - Pressing enter doesn't do anything when pushing translations
Summary: Pressing enter doesn't do anything when pushing translations
Keywords:
Status: NEW
Alias: None
Product: PressGang CCMS
Classification: Community
Component: CSProcessor
Version: 1.8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: pressgang-ccms-dev
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-18 03:41 UTC by Lee Newson
Modified: 2014-08-18 03:41 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Lee Newson 2014-08-18 03:41:05 UTC
From an email that was sent to me:

------------------------------------------------------------------------
You are about to push 135 topics to zanata. Continue? (Yes/No)

<press Enter here>
(Expected either repeat of question or "please choose y/n" or something.)

This is what you get:

Output:
Topics successfully pushed to Zanata for translation.

That happens immediately and you get dropped back to a prompt. If
instead you type "y" or "Yes", you get this:

You are about to push 135 topics to zanata. Continue? (Yes/No)
y
Starting to push topics to zanata...
        Pushing topics to zanata 5% Done
        Pushing topics to zanata 10% Done
etc.
------------------------------------------------------------------------

This as mentioned should be asking again or using a default. All that is happening at the moment is when the answer isn't yes/no then the program prints the success message and exits without doing anything.


Note You need to log in before you can comment on or make changes to this bug.