Bug 113111 - Bug in parted causes installer to crash
Bug in parted causes installer to crash
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-08 11:03 EST by Troy Dawson
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-25 15:43:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda dump (371.52 KB, text/plain)
2004-01-08 11:05 EST, Troy Dawson
no flags Details
syslog from traceback (10.29 KB, text/plain)
2004-01-08 11:05 EST, Troy Dawson
no flags Details

  None (edit)
Description Troy Dawson 2004-01-08 11:03:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031016

Description of problem:
I am installing Fedora Core 1 on a machine with one normal sized
system disk and 2 large (1.5 Terabyte) data disks.  The data disks
have already been formated.  Each one has one large 1.5 Terrabyte ext3
filesystem.
I manually partitioned using Disk Druid, but did not touch either of
the data drives, either to format or have them mounted, or even
clicked on them.
Everything went fine until it actually starts to format and install
(right after the about-to-install screen).  You then get the error
reported in Bug 109987, mainly
---
Error informing kernel about modifications to partition /dev/sdb1 -
Invalid argument.  This means Linux won't know about any changes you
made to /dev/sdb1 until you reboot - so you shouldn't mount it or use
it in any way before rebooting
---
It then gives a <ignore> <cancel> option, both of which give a traceback.

I have tried this in both GUI and text mode, with Fedora Core 1 and
RedHat 9, all with the exact same results.

I have also tried it with the drives mounted and as I said before, not
touching them at all.

One of the drives I was able to wipe out and try some repartitioning.
 I found that the error message seens is from parted for when I do a
partition over 1.1 Terrabye.  I also found that using fdisk
repartitions the drive fine.  I also found that with no paritions on
that disk, I get the error for the next one (/dev/sdc1).

So in short, although parted is giving that error, anaconda shouldn't
be touching those partitions in the first place, and/or if it does, it
shouldn't be completely failing.
There is no way for me to do this installation without either removing
the disks (This is all internal, it's not an easy thing to do) or
wiping out my final large filesystem.

Version-Release number of selected component (if applicable):
anaconda-9.2-2

How reproducible:
Always

Steps to Reproduce:
1.Have a filesystem larger than 1.2 terrabyte's
2.Run the install
3.
    

Actual Results:  When it get's to the 'installing-packages' where it
does the formatting, it puts up a error message.  After clicking on
either ignore or cancle, the install bombs with a traceback.

Expected Results:  Since these partitions were never supposed to be
touched, I expect them never to be touched.  Since they were, and an
error occured, I then expected them to fail, but not be fatal

Additional info:
Comment 1 Troy Dawson 2004-01-08 11:05:04 EST
Created attachment 96830 [details]
anaconda dump
Comment 2 Troy Dawson 2004-01-08 11:05:41 EST
Created attachment 96831 [details]
syslog from traceback
Comment 3 Jeremy Katz 2004-06-25 15:43:04 EDT
This gets fixed by the 2.6 kernel in FC2 and later

Note You need to log in before you can comment on or make changes to this bug.