This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 113126 - emacs can't open unicode(jp) filenames
emacs can't open unicode(jp) filenames
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: MoveUpstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-08 13:24 EST by P Jones
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 04:56:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description P Jones 2004-01-08 13:24:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
When I try to open a file with unicode name, emacs doesn't open the
file (presents me with a blank buffer) and has a escaped(and wrong)
name as the name of the buffer.  I tested this as Japanese.


Version-Release number of selected component (if applicable):
emacs-21.3-7

How reproducible:
Always

Steps to Reproduce:
0. Install with emacs and Japanese language.
1. Log in as japanese (LANG=ja_JP.UTF8).
2. open a terminal
3. create a unicode filename (echo hi > ��test) (shift-space s u enter
shift-space for the magic char)
4. open it with "emacs ��test" 
5. Note the filename in emacs is "a\201\231test" and doesn't have "hi"
in it.
6. Go to File->open file and open enter the filename.
7. Note the filename is correct and the contents are correct.

Additional info:

I also tried this with vim and gedit to make sure it wasn't something
more fundimental, but it looks like emacs just isn't parsing command
lines with i18n in mind.
Comment 1 Jens Petersen 2004-01-14 02:47:34 EST
Reproduced.

Probably a good idea to ask the Emacs developers about this.
Comment 2 Jens Petersen 2004-01-14 19:58:44 EST
Reproduced with cvs emacs too fwiw.
Comment 3 Jens Petersen 2004-09-29 04:56:16 EDT
Seems to be fixed in cvs emacs as of July anyway.

Note You need to log in before you can comment on or make changes to this bug.