Bug 113129 - Up2date GUI hangs on new kernel update
Up2date GUI hangs on new kernel update
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Bret McMillan
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-08 13:55 EST by Charles E Patrick III
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:31:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Charles E Patrick III 2004-01-08 13:55:07 EST
Description of problem:
After updating the kernel-2.4.21-4.0.2.EL via the up2date GUI the
"Installing Packages" window hangs (w/hourglass cursor) when the
progress bar shows completed (all the way to the right).  The Back and
Forward buttons remain grayed out.  The GUI remained in this state
overnight.  It appears to have completed the install (see additional
info below).

Version-Release number of selected component (if applicable):
up2date-4.0.1-1
up2date-gnome-4.0.1-1

How reproducible:
It happend twice on two different machines, each on the kernel update
for clean installs.

Steps to Reproduce:
1. Install RHEL WS
2. Get initial updates including new kernel package
  
Actual results:


Expected results:


Additional info:
Running up2date on the command line "up2date -uf" produces the following:
-- begin --
Fetching package list for channel: rhel-i386-ws-3...
########################################
Fetching Obsoletes list for channel: rhel-i386-ws-3...
 
Name                                    Version        Rel
----------------------------------------------------------
kernel                                  2.4.21         4.0.2.EL      
     i686                                                            
                    
 
Testing package set / solving RPM inter-dependencies...
########################################
RPM package conflict error.  The message was:
Test install failed because of package conflicts:
package kernel-2.4.21-4.0.2.EL is already installed
-- end --
Comment 1 Frank Stratton 2004-09-30 08:32:08 EDT
I have the same problem with Fedora Core 2.  I notice that this only
happens with certain sites.  

For instance: mirror.eas.muohio.edu/fedora/linux/core/updates/2/i386

This site seems to be down and when I see that this mirror is being
used I always get the progress bar all the way to the right.   I then
cancel the operation and try until I get a different mirror site.  The
sunsite seems to always work.
Comment 2 RHEL Product and Program Management 2007-10-19 15:31:36 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.