Bug 113131 - Folder browser is extremely slow when not sitewide admin
Folder browser is extremely slow when not sitewide admin
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise CMS
Classification: Retired
Component: ui (Show other bugs)
nightly
All Linux
medium Severity high
: ---
: ---
Assigned To: Bryan Che
Jon Orris
:
Depends On:
Blocks: 106481
  Show dependency treegraph
 
Reported: 2004-01-08 14:06 EST by Matthew Booth
Modified: 2007-04-18 13:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-11 16:39:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Booth 2004-01-08 14:06:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4)
Gecko/20030701 Epiphany/1.0

Description of problem:
The folder browser uses both old and new style permission filters.
When logged in as a sitewide admin these filters aren't added in to
the query because the user has universal admin permission. When they
are executed, they run extremely slowly.

This was fixed on the london 5.2 branch by removing the old style
permission filter. Note the new one is still there, so the results are
the same. I've ported the relevant changelists to my rickshaw CMS
branch in changelist 39210.

On a populated database, a page load was taking 83 seconds. After this
change the same page was loading in .8 seconds.

Version-Release number of selected component (if applicable):
Richshaw

How reproducible:
Always

Steps to Reproduce:
1. Add some content to CMS.
2. Log in as a regular (non sitewide admin user).
3. Go to /ccm/content/admin and click around in the folder browser.
    

Actual Results:  Page loads take an unacceptable amount of time (eg 83
seconds).

Expected Results:  Page loads take a regular amount of time.

Additional info:
Comment 1 Richard Li 2004-01-08 15:34:13 EST
We haven't landed the test-permissions branch yet, which completely
overhauls the permissions denormalizations. We should retest this
scenario after the land, but hopefully it should be addressed by the
new denormalization.
Comment 2 Richard Li 2004-01-23 08:27:25 EST
i believe this is resolved now with the permissions branch land
Comment 3 Jon Orris 2004-01-27 16:44:53 EST
The response time seems good just from testing, but I haven't taken
any scaling measurements. Matt, can you verify your prior test? 
Comment 4 Bryan Che 2004-03-11 16:39:40 EST
folder browsing survives load testing as non-sitewide-admin now

Note You need to log in before you can comment on or make changes to this bug.