Bug 113158 - hang attempting the create new printer definition
hang attempting the create new printer definition
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: foomatic (Show other bugs)
1
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
: 113794 114975 116728 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-08 19:20 EST by Gene Czarcinski
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-04 07:34:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
foomatic-db-engine-segfault.patch (966 bytes, patch)
2004-01-09 05:45 EST, Tim Waugh
no flags Details | Diff

  None (edit)
Description Gene Czarcinski 2004-01-08 19:20:52 EST
Description of problem:
First try on Opteron system running the "preview" of x86_64 FC1

Version-Release number of selected component (if applicable):
redhat-config-printer-0.6.79.2-1

Invoked printconf from a terminal window and got:

Traceback (most recent call last):
  File "/usr/share/printconf/util/queueTree.py", line 537, in
new_button_clicked    self.use_foomatic ()
  File "/usr/share/printconf/util/queueTree.py", line 467, in use_foomatic
    self.conf.foomatic_init_overview ()
  File "/usr/share/printconf/util/printconf_conf.py", line 1554, in
foomatic_init_overview
    root = parser.parse (foo)
  File
"/usr/src/build/288888-x86_64/install/usr/lib64/python2.2/site-packages/_xmlplus/utils/qp_xml.py",
line 134, in parse
xml.parsers.expat.ExpatError: no element found: line 1, column 0
Comment 1 Tim Waugh 2004-01-09 04:11:23 EST
What does 'foomatic-configure -O' say?
Comment 2 Gene Czarcinski 2004-01-09 05:20:48 EST
nothing (no output) ... either as root or regular user.

I also ran it on my "regluar" Athlon system and see that it is suppose
to produce lots of xml but on the Opteron ... nothing.
Comment 3 Tim Waugh 2004-01-09 05:45:07 EST
Created attachment 96855 [details]
foomatic-db-engine-segfault.patch

Please try this patch.
Comment 4 Tim Waugh 2004-01-09 05:45:34 EST
Incidentally, this issue is already fixed upstream and in rawhide.
Comment 5 Gene Czarcinski 2004-01-09 07:17:06 EST
Unless you have some overriding reason to try the patch, I would just
as soon pull the updates rpm from rawhide (development).
Comment 6 Gene Czarcinski 2004-01-09 12:10:48 EST
OK, I downloaded foomatic-3.0.0-17.x86_64.rpm from development and
installed it.

printer configuration still does not work.

The output of running foomatic-configure -O is:

Can't locate Foomatic/Defaults.pm in @INC (@INC contains:
/usr/lib64/perl5/5.8.1/x86_64-linux-thread-multi /usr/lib/perl5/5.8.1
/usr/lib64/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.1
/usr/lib/perl5/site_perl
/usr/lib64/perl5/vendor_perl/5.8.1/x86_64-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl/5.8.0
/usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.1 .) at
/usr/bin/foomatic-configure line 14.
BEGIN failed--compilation aborted at /usr/bin/foomatic-configure line 14.
Comment 7 Tim Waugh 2004-01-09 12:25:16 EST
Recompile it against the perl you're actually running. :-)
Comment 8 Gene Czarcinski 2004-01-09 13:37:03 EST
When I grab something from rawhide/development, I "always" get the
src.rpm and rebuild so that it works with the libs, etc. I am running
... except this time.

OK, rebuilt the src rpm and installed ... print config now works.

BTW, it sure does take a lot of CPU to rebuild foomatic  ... I thought
I found another bug like the one I found in gcc where it looped with
gcc -O2.
Comment 9 Tim Waugh 2004-01-18 07:53:45 EST
*** Bug 113794 has been marked as a duplicate of this bug. ***
Comment 10 Justin M. Forbes 2004-02-04 23:59:44 EST
*** Bug 114975 has been marked as a duplicate of this bug. ***
Comment 11 Tim Waugh 2004-02-13 10:06:55 EST
The bug is fixed in the foomatic update for Fedora Core 1, which you
can recompile the SRPM for.
Comment 12 Justin M. Forbes 2004-02-24 14:49:26 EST
*** Bug 116728 has been marked as a duplicate of this bug. ***
Comment 13 Justin M. Forbes 2004-03-04 01:16:48 EST
This seems to be working with the applied updates, which should ship
with FC1 release. Tested on multiple systems here, should we close
this one?
Comment 14 Gene Czarcinski 2004-03-04 07:34:24 EST
yes, fixed in footmatic-3.0.0-21.3

I am closing as fixed in errata

Note You need to log in before you can comment on or make changes to this bug.