This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 113189 - build fails with "--define 'oracle 1'"
build fails with "--define 'oracle 1'"
Status: CLOSED DUPLICATE of bug 110482
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
1
All Linux
low Severity low
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-09 09:51 EST by Nikola Vassilev
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikola Vassilev 2004-01-09 09:51:14 EST
Description of problem:

When I try to compile php-4.3.4-1.1 with Oracle oci8 plugin, the 
build fails at the packaging step.

If I modify the spec file, at line 402 from:

for mod in pgsql mysql odbc imap ldap snmp domxml xmlrpc %{!?
oracle:oci8} %{!?mssql:mssql}; do

to this:

for mod in pgsql mysql odbc imap ldap snmp domxml xmlrpc oci8 %{!?
mssql:mssql}; do

Then the build finishes ok. I don't think that "fix" would be correct 
for builds without the oracle module. I am not sure how to fix this 
properly.

Version-Release number of selected component (if applicable): php-
4.3.4-1.1


How reproducible: every time

Steps to Reproduce:
1. Instal Oracle client & libraries
2. Build php from srource rpm with oracle oci8 support

Actual results:
RPM build errors:
    Could not open %files file /usr/src/redhat/BUILD/php-
4.3.4/files.oci8: No such file or directory

Expected results:
With "fix" described above:

Wrote: /usr/src/redhat/RPMS/i386/php-4.3.4-1.1.i386.rpm
Wrote: /usr/src/redhat/RPMS/i386/php-devel-4.3.4-1.1.i386.rpm
Wrote: /usr/src/redhat/RPMS/i386/php-imap-4.3.4-1.1.i386.rpm
Wrote: /usr/src/redhat/RPMS/i386/php-ldap-4.3.4-1.1.i386.rpm
Wrote: /usr/src/redhat/RPMS/i386/php-mysql-4.3.4-1.1.i386.rpm
Wrote: /usr/src/redhat/RPMS/i386/php-pgsql-4.3.4-1.1.i386.rpm
Wrote: /usr/src/redhat/RPMS/i386/php-odbc-4.3.4-1.1.i386.rpm
Wrote: /usr/src/redhat/RPMS/i386/php-oci8-4.3.4-1.1.i386.rpm
Wrote: /usr/src/redhat/RPMS/i386/php-snmp-4.3.4-1.1.i386.rpm
Wrote: /usr/src/redhat/RPMS/i386/php-domxml-4.3.4-1.1.i386.rpm
Wrote: /usr/src/redhat/RPMS/i386/php-xmlrpc-4.3.4-1.1.i386.rpm
Wrote: /usr/src/redhat/RPMS/i386/php-debuginfo-4.3.4-1.1.i386.rpm
Executing(%clean): /bin/sh -e /var/tmp/rpm-tmp.45052
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd php-4.3.4
+ '[' /var/tmp/php-root '!=' / ']'
+ rm -rf /var/tmp/php-root
+ rm files.domxml files.imap files.ldap files.mysql files.oci8 
files.odbc files.pgsql files.snmp files.xmlrpc
+ exit 0
Executing(--clean): /bin/sh -e /var/tmp/rpm-tmp.45052
+ umask 022
+ cd /usr/src/redhat/BUILD
+ rm -rf php-4.3.4
+ exit 0
Comment 1 Joe Orton 2004-01-09 09:53:00 EST
Please try 4.3.4-2 or later from Raw Hide.

*** This bug has been marked as a duplicate of 110482 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:00:40 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.