Bug 113220 - TypeError: len() of unsized object
TypeError: len() of unsized object
Status: CLOSED DUPLICATE of bug 113277
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-09 15:43 EST by Mike McLean
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McLean 2004-01-09 15:43:23 EST
* rawhide-20040109
* root_fs_on_lvm english http TUI

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 1120, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/src/build/335883-i386/install//usr/lib/anaconda/text.py",
line 474, in run
  File
"/usr/src/build/335883-i386/install//usr/lib/anaconda/dispatch.py",
line 168, in gotoNext
  File
"/usr/src/build/335883-i386/install//usr/lib/anaconda/dispatch.py",
line 236, in moveStep
  File
"/usr/src/build/335883-i386/install//usr/lib/anaconda/packages.py",
line 792, in doInstall
TypeError: len() of unsized object
Comment 2 Jeremy Katz 2004-01-11 00:06:12 EST
dwalsh told me about this.  New rpm broke things, built anaconda with
a fix for it.
Comment 3 Mike McLean 2004-01-19 15:33:05 EST
Still broken in rawhide-20040119 (anaconda-9.3-0.20040114155239)

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 1047, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 242, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 766, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 168, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 236, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 792, in doInstall
    totalFiles = totalFiles + len(p[rpm.RPMTAG_BASENAMES])
TypeError: len() of unsized object

Comment 5 Jeremy Katz 2004-01-19 17:24:55 EST

*** This bug has been marked as a duplicate of 113277 ***
Comment 6 Red Hat Bugzilla 2006-02-21 14:00:42 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.