Bug 113239 - Dogs when it is installed and when trying to reinstall it.
Dogs when it is installed and when trying to reinstall it.
Status: CLOSED DEFERRED
Product: Red Hat Raw Hide
Classification: Retired
Component: net-snmp (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-10 00:39 EST by Jim Cornette
Modified: 2015-03-04 20:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-10 17:32:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Cornette 2004-01-10 00:39:08 EST
Description of problem:

Using Up2date to retrieve prpgram rpms. Error on conflicts below

Version-Release number of selected component (if applicable):

net-snmp-5.1-3

How reproducible:

When selecting programs that would conflict with net-snmp requirements
the below happens.

Steps to Reproduce:
1.run up2date -u from terminal or up2date from gui
2. get error aboun dependacies not met
3.
  
Actual results:

Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:
 
Unresolvable chain of dependencies:
net-snmp  5.1-3                          requires librpm-4.2.so
net-snmp  5.1-3                          requires librpmdb-4.2.so
net-snmp  5.1-3                          requires librpmio-4.2.so


Expected results:

 up2date could resolve all conflicts with requirements. I only have
rawhide versions installed. (development) No other repo is being used.
(testing/ updates, etc)

Additional info:

To see if the upgrade would complete without net-snmp installed, I
tried to uninstall net-snmp and got these errors.

 rpm -e net-snmp
error: Failed dependencies:
        libnetsnmp.so.5 is needed by (installed) kdeutils-3.1.94-0.1
        libnetsnmp.so.5 is needed by (installed) ethereal-0.10.0a-1
        net-snmp >= 5.0 is needed by (installed) ethereal-0.10.0a-1

I then ran 'rpm -e net-snmp --nodeps' and tried to reinstall it again
after the other programs successfuly installed through up2date.

 up2date net-snmp --nosig

Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:
 
Unresolvable chain of dependencies:
net-snmp  5.1-3                          requires librpm-4.2.so
net-snmp  5.1-3                          requires librpmdb-4.2.so
net-snmp  5.1-3                          requires librpmio-4.2.so



There is not really much here to I hope the inline screen errors are
not too irritating.  A conflict exists before removal and also upon
re-installation.
Comment 1 Kaj J. Niemi 2004-01-10 08:48:08 EST
You need to upgrade rpm on your system. Rawhide's net-snmp is compiled
against a later version than what you have installed.

% rpm -q --whatprovides librpm-4.2.so librpmdb-4.2.so librpmio-4.2.so
rpm-4.2.2-0.8
rpm-4.2.2-0.8
rpm-4.2.2-0.8
Comment 2 Kaj J. Niemi 2004-01-10 08:48:30 EST
This is not really a net-snmp bug.
Comment 3 Jim Cornette 2004-01-10 09:25:10 EST
I have rpm-4.3-0.6 installed from Rawhide installed.

rpm -q --whatprovides librpm-4.2.so librpmdb-4.2.so librpmio-4.2.so
no package provides librpm-4.2.so
no package provides librpmdb-4.2.so
no package provides librpmio-4.2.so

If I change the 2 portion to a 3. I get the below output. Should I
just download the src rpm and rebuild it? Or is there going to be
compiled against a newer rpm released?

My system outputs

> rpm -q --whatprovides librpm-4.3.so librpmdb-4.3.so librpmio-4.3.so
rpm-4.3-0.6
rpm-4.3-0.6
rpm-4.3-0.6


Thanks,

Jim
Comment 4 Kaj J. Niemi 2004-01-10 09:33:43 EST
My guess would be that net-snmp would be eventually rebuilt, don't
know when :) rpm-4.3-0.6 came to rawhide like yesterday or so. 

If you don't want to wait there's always the option of rebuilding as
you mentioned yourself. I'd change the release to "3.0.1" (if the
current in rawhide is "3") as the next rawhide version would most
likely be "4" or "3.1" and you'd automagically get a newer release
installed on top of your own build.

Comment 5 Jim Cornette 2004-01-10 17:32:22 EST
Thanks for the information and pointers. There are not many conflicts
from an all rawhide distro, except the problem that I experienced with
xmms not making a default directory, if none existed, (new
installation or new account) and the conflict with net-snmp.

I'll change the resolution to deferred for the next build.

Thanks,
Comment 6 Phil Knirsch 2004-01-12 03:37:53 EST
Hi folks!

Just to let you know, i'll bump the release today and will rebuild
net-snmp, so everything should be in order in the next few days.

Thanks,

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.