Bug 1132497 - missing soft link /usr/lib64/libnepomukcleaner.so
Summary: missing soft link /usr/lib64/libnepomukcleaner.so
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nepomuk-core
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Reznik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-21 12:54 UTC by Dj YB
Modified: 2014-09-09 22:16 UTC (History)
6 users (show)

Fixed In Version: nepomuk-core-4.11.5-2.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-09 22:11:14 UTC


Attachments (Terms of Use)

Description Dj YB 2014-08-21 12:54:56 UTC
Description of problem:
missing soft link /usr/lib64/libnepomukcleaner.so

Version-Release number of selected component (if applicable):
nepomuk-core-libs-4.13.3-1.fc20.x86_64

How reproducible:
allways

Steps to Reproduce:
1.install package
2.
3.

Actual results:
link missing

Expected results:
link not missing

Additional info:
Thank you

Comment 1 Rex Dieter 2014-08-21 13:11:50 UTC
The symlink is in nepomuk-core-devel pkg

Comment 2 Rex Dieter 2014-08-21 13:12:32 UTC
Or, hmm... we actually don't package the symlink at all, since there's no api for it.

Why do you need it?

Comment 3 Dj YB 2014-08-21 13:20:57 UTC
It was required to compile nepomuktvnamer, took me a while to get it

Comment 4 Rex Dieter 2014-08-21 14:06:31 UTC
OK, I'll put it back

Comment 5 Rex Dieter 2014-08-21 14:08:33 UTC
On second thought, if nepomuktvnamer needs it, why are all these builds succeeding (when it is currently unpackaged)?

http://koji.fedoraproject.org/koji/packageinfo?packageID=15190

Comment 6 Rex Dieter 2014-08-21 14:19:31 UTC
To answer my own question, seems nepomuktvnamer-0.2.54 uses it (even though it's not a public api afaict). 

No biggie, I'll put it back then.

Comment 7 Fedora Update System 2014-08-21 15:20:24 UTC
nepomuk-core-4.13.3-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/nepomuk-core-4.13.3-2.fc20

Comment 8 Fedora Update System 2014-08-21 15:21:01 UTC
nepomuk-core-4.11.5-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/nepomuk-core-4.11.5-2.fc19

Comment 9 Rex Dieter 2014-08-21 15:21:39 UTC
submitting buildroot overrides now too so you can build against these.

Comment 10 Dj YB 2014-08-21 15:38:23 UTC
thanks

Comment 11 Fedora Update System 2014-08-23 01:54:24 UTC
Package nepomuk-core-4.13.3-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing nepomuk-core-4.13.3-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-9667/nepomuk-core-4.13.3-2.fc20
then log in and leave karma (feedback).

Comment 12 Dj YB 2014-08-23 18:20:11 UTC
Thanks
I have already created the link manually in order to build nepomuktvnamer and I don't have a login to the Fedora Update System.

Comment 13 Fedora Update System 2014-09-09 22:11:14 UTC
nepomuk-core-4.13.3-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2014-09-09 22:16:57 UTC
nepomuk-core-4.11.5-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.