Bug 113263 - Glyph errors in Cyrillic fonts.
Glyph errors in Cyrillic fonts.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-11 09:46 EST by Mattias Ellert
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-12 11:07:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The Cyrillic block in the serif font (120.85 KB, image/png)
2004-01-11 09:49 EST, Mattias Ellert
no flags Details
The Cyrillic block in the sans font (112.25 KB, image/png)
2004-01-11 09:50 EST, Mattias Ellert
no flags Details
The Cyrillic block in the monospace font (106.73 KB, image/png)
2004-01-11 09:52 EST, Mattias Ellert
no flags Details

  None (edit)
Description Mattias Ellert 2004-01-11 09:46:36 EST
Description of problem:
Some letters in the Cyrillic block are shown with wrong glyphs.

Version-Release number of selected component (if applicable):
XFree86-4.3.0-42

How reproducible:
Always

Steps to Reproduce:
1. Open the Unicode Character Map Accessory
2. Select the Cyrillic Block
3. Inspect the glyphs for serif, sans and monospace
  
Actual results:
Some glyphs are wrong

Expected results:
All glyphs should be correct

Additional info:

serif:

040B: The glyph is squeezed and looks like a strange mixture between a
capital and a small letter. The glyph should look more like the glyph
shown for 04BA, but with the top bar added.

04A8, 04A9: The loop is missing.

04BB: The glyph should look more like 045B, but without the bar.

04BC, 04BD: The little hook on the left is missing.

04BE, 04BF: The little hook on the left and the descender are missing.

sans and monospace:

0402: The glyph should not connect at the bottom (compare to the glyph
shown on the serif font).

040B, 0452, 045B: These glyphs should not look like T's.

0494, 0495: The middle hook is missing.

0496, 0497, 0498, 0499, 049A, 049B: The descender is missing.

049C, 049D: The vertical stroke is missing (sans only).

04A0, 04A1: The top stroke to the left is missing.

04A2, 04A3: The descender is missing.

04A4, 04A5: The top stroke to the right is missing (monospace only).

04A6, 04A7: The middle hook is missing.

04A8, 04A9: The loop is missing.

04AA, 04AB, 04AC, 04AD: The descender is missing.

04AF: The stem is missing (sans only).

04B0: The stroke is missing (sans only).

04B1: The stem and the stroke are missing (sans only).

04B2, 04B3: The descender is missing.

04B4, 04B5: The top bar is missing.

04B6, 04B7: The descender is missing.

04B8, 04B9: The vertical stroke is missing (sans only).

04BB: This should look more like 045B (after that glyph has been
corrected), but without the bar.

04BC, 04BD: The little hook on the left is missing. For monospace the
base letter should be changed from a c shape to an e shape.

04BE, 04BF: The little hook on the left and the descender are missing.
For monospace the base letter should be changed from a c shape to an e
shape.

04C3, 04C4: The hook is missing.

04C7, 04C8: The hook is missing.

04CB, 04CC: The left descender is missing.

04E0, 04E1: The top of the glyph should be flat.
Comment 1 Mattias Ellert 2004-01-11 09:49:05 EST
Created attachment 96878 [details]
The Cyrillic block in the serif font
Comment 2 Mattias Ellert 2004-01-11 09:50:29 EST
Created attachment 96879 [details]
The Cyrillic block in the sans font
Comment 3 Mattias Ellert 2004-01-11 09:52:30 EST
Created attachment 96880 [details]
The Cyrillic block in the monospace font
Comment 4 Mike A. Harris 2004-01-12 11:07:02 EST
We (Red Hat) do not design, edit, modify fonts or do any form of
fontography work.  The fonts included with the distribution are
included on an as-is basis, and many (most) of the fonts have
licenses which permit widspread distribution, but do not permit
modification and redistribution.

If you discover flaws in any particular font file, please contact
the original author and copyright owner of the given font file
directly, if you find any kind of errors in a font.  Alternatively,
you can contact XFree86.org via their bugzilla located at
http://bugs.xfree86.org, however they do not do fontography work
to my knowledge either, and are also subject to the licensing
restrictions that do not permit modification and redistribution,
and are likely to redirect you to the original font author and
copyright holder as well.

Closing WONTFIX

Note You need to log in before you can comment on or make changes to this bug.