Bug 113269 - httpd segmentation faults if CookieTracking is on
httpd segmentation faults if CookieTracking is on
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Joe Orton
http://nagoya.apache.org/bugzilla/sho...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-11 14:11 EST by Jason Rothstein
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 2.0.49-1.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-20 05:19:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Rothstein 2004-01-11 14:11:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b)
Gecko/20031208

Description of problem:
When cookie tracking is turned on, all requests from a browser that
accepts the cookie after the first request will cause httpd to
segmentation fault with a signal 11.

Version-Release number of selected component (if applicable):
2.0.48-1.2

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora, Custom install, Everything for package selection
2. Apply all existing updates via "yum -y update"
3. put "CookieTracking On" into a file in /etc/httpd/conf.d/
4. restart httpd service
5. use any browser that accepts cookies to view the default test page.

Actual Results:  Lynx would give "unexpected network error" on the 2nd
request and all further requests to pages at that server name.

Expected Results:  Lynx and other browsers would recieve the
cookietracking cookie and be able to make further 

Additional info:

Reporduced on 2 machines thus far. One is AMD Duron 1.3, other is AMD
K6-2/500.
Comment 1 Joe Orton 2004-01-11 17:35:20 EST
Yes, the workaround is to add:

"CookieName Apache"

to your httpd.conf somewhere.
Comment 2 Jason Rothstein 2004-01-11 19:51:19 EST
Workaround works for me
Comment 3 Joe Orton 2004-07-20 05:19:17 EDT
This was fixed in the 2.0.49 update also.  Thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.