Bug 113296 - Partition table refused if not covering complete disk
Partition table refused if not covering complete disk
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-12 05:56 EST by Etienne Lorrain
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-10 04:38:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Etienne Lorrain 2004-01-12 05:56:55 EST
Description of problem:

  I have a perfectly valid partition table, but with some empty space 
at end of the disk because that is where my bootloader is located 
(Gujin at sourceforge).
The bootloader is hidding its own code by setting the HPA of IDE disk 
before running the OS selected.
 When installing Fedora 1 (so booting from CDROM), if the partition 
table is like this, the only choice is to reset the partition table 
to zero before continuing:

found partition type 0x16 (OSnumber 1), start 63 (63 + 0), length 
1060227 (ends at 1060290) [0/1/1 to 65/254/63]
found partition type 0x83 (OSnumber 2), start 1060290 (1060290 + 0), 
length 20482875 (ends at 21543165) [66/0/1 to 1023/254/63]
found partition type 0xC (OSnumber 3), start 21543165 (21543165 + 0), 
length 12289725 (ends at 33832890) [1023/254/63 to 1023/254/63]
found extended partition type 0xF (OSnumber 4), start 33832890 
(33832890 + 0), length 81931500 (ends at 115764390) [1023/254/63 to 
1023/254/63]
Analysing extended partition type 0xF, start 33832890 (33832890 + 0), 
length 81931500...

  If the partition table is like this the installation works without 
problem (i.e. the complete partition table is recognised and used):

found partition type 0x16 (OSnumber 1), start 63 (63 + 0), length 
1060227 (ends at 1060290) [0/1/1 to 65/254/63]
found partition type 0x83 (OSnumber 2), start 1060290 (1060290 + 0), 
length 20482875 (ends at 21543165) [66/0/1 to 1023/254/63]
found partition type 0xC (OSnumber 3), start 21543165 (21543165 + 0), 
length 12289725 (ends at 33832890) [1023/254/63 to 1023/254/63]
found extended partition type 0xF (OSnumber 4), start 33832890 
(33832890 + 0), length 83425545 (ends at 117258435) [1023/254/63 to 
1023/254/63]
Analysing extended partition type 0xF, start 33832890 (33832890 + 0), 
length 83425545...

  The disk size is 117266688 sectors and those numbers are extracted 
from running Gujin dbgdisk.exe from a DOS floppy (sourceforge -> 
Gujin -> standard.tgz -> dbgdisk.exe).
 The extended partition is full of stuff, but the real difference is 
its size: Fedora 1 does not accept a smaller size than the complete 
disk size - RedHat 9 accepted the reduced size without problem.
 In the two cases the extended partition size is big enought to 
contain all the partitions in it. Another way to describe the problem 
is that with Fedora the non-mapped area has to be inside the extended 
partition, with RH9 and other operating systems it can also be 
outside any partition.
 When Gujin loads an OS, it usually set the Host Protected Area to 
117201143 - after that is its "reserved area".


Version-Release number of selected component (if applicable):
Fedora 1

How reproducible:
Every times

Steps to Reproduce:
1. Try to install with such a partition table.
2.
3.
  
Actual results:


Expected results:
 The partition table should be accepted even if it does not cover the
whole disk size (the disk size may change because it can be set by an 
IDE command - the only problem then is that the BIOS is a bit 
confused - so the HPA feature with password is a better choice).

Additional info:
Comment 1 Jeremy Katz 2004-06-25 15:44:22 EDT
Does this still happen with FC2?
Comment 2 Etienne Lorrain 2004-07-06 04:37:23 EDT
 Yes, with Fedora core 2, at installation time, you get either the 
choice to ignore completely the HD or to reset its partition table.
 I digged a bit more, and a partition table with a minimum size for 
the extended partition (i.e. only the size which is necessary to fit 
all the "logical" partitions) can also be obtained by using fdisk of 
MS-DOS v6.2 (where you can enter the size of the extended partition 
you are creating). If I remember well the FDISK of MSDOS > 6.2 do not 
ask the question and assign the complete size of the HD.
 Fell free to ask more info if needed, I may not be precise enought.

Note You need to log in before you can comment on or make changes to this bug.