Bug 11330 - Mouse and Keyboard fail during operation 1-2 minutes
Mouse and Keyboard fail during operation 1-2 minutes
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-09 12:33 EDT by Leigh L. Klotz, Jr.
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-30 16:35:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86Config (8.30 KB, text/plain)
2000-05-09 12:34 EDT, Leigh L. Klotz, Jr.
no flags Details
xdpyinfo output (3.10 KB, text/plain)
2000-05-09 12:34 EDT, Leigh L. Klotz, Jr.
no flags Details

  None (edit)
Description Leigh L. Klotz, Jr. 2000-05-09 12:33:34 EDT
This problem looks most like bug 6958 but I am using 800x600
on a DEC Hinote Ultra II laptop with a CT65548, not the 32 or 24 bit color
mentioned in bug 6958.

Here are the symptoms: I run gnome and when I am using either Netscape
(upgraded from 4.6 to 4.72, still happens) or the RedHat help browser, the
mouse and keyboard freeze after a minute or two.  I've tried turning off
images in Netscape but it still happens.  It seems to happen a lot when I
use the scrollbar, but it happens at other times as well.  I can log in via
telnet, and I can see output on the screen continue to update and run, I
just can't use the kbd or mouse.  (No ctrl-alt-del, for example.)

I have installed Linux 6.1 as the only OS.  I have verified mouse and kbd
operation under Win98 with a separate disk drive.   In an attempt to fix
the problem I went to the errata page and updated all of the packages that
I could think were relevant (various graphics libs, etc.).  I also tried
removing the 3-button emulation, but that didn't help. (I tried to do the
kernel update as well but it was unable to recognize my PCMCIA ethernet
card afterwards so I rolled back -- but that's a different problem.)

I note that I was unable to use the automated installer with RedHat 6.1 to
install X -- it got a python error trying to find the server.  This is
logged as Red Hat Service Request 143389, since it was an installation
problem.)

Here is my XF86Config file, followed by the output of xpdyinfo.

# File generated by XConfigurator.

# **********************************************************************
# Refer to the XF86Config(4/5) man page for details about the format of
# this file.
# **********************************************************************

# **********************************************************************
# Files section.  This allows default font and rgb paths to be set
# **********************************************************************

Section "Files"

# The location of the RGB database.  Note, this is the name of the
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.

    RgbPath	"/usr/X11R6/lib/X11/rgb"

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

    FontPath   "unix/:-1"

EndSection

# **********************************************************************
# Server flags section.
# **********************************************************************

Section "ServerFlags"

    # Uncomment this to cause a core dump at the spot where a signal is
    # received.  This may leave the console in an unusable state, but may
    # provide a better stack trace in the core dump to aid in debugging
    #NoTrapSignals

    # Uncomment this to disable the <Crtl><Alt><BS> server abort sequence
    # This allows clients to receive this key event.
    #DontZap

    # Uncomment this to disable the <Crtl><Alt><KP_+>/<KP_-> mode switching
    # sequences.  This allows clients to receive these key events.
    #DontZoom

EndSection

# **********************************************************************
# Input devices
# **********************************************************************

# **********************************************************************
# Keyboard section
# **********************************************************************

Section "Keyboard"

    Protocol    "Standard"

    # when using XQUEUE, comment out the above line, and uncomment the
    # following line
    #Protocol   "Xqueue"

    AutoRepeat  500 5

    # Let the server do the NumLock processing.  This should only be
    # required when using pre-R6 clients
    #ServerNumLock

    # Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
    #Xleds      1 2 3

    #To set the LeftAlt to Meta, RightAlt key to ModeShift,
    #RightCtl key to Compose, and ScrollLock key to ModeLock:

    LeftAlt        Meta
    RightAlt        Meta
   ScrollLock      Compose
   RightCtl        Control

# To disable the XKEYBOARD extension, uncomment XkbDisable.

#    XkbDisable

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#    XkbModel    "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#    XkbModel    "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#    XkbLayout   "de"
# or:
#    XkbLayout   "de"
#    XkbVariant  "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#    XkbOptions  "ctrl:swapcaps"

# These are the default XKB settings for XFree86
#    XkbRules    "xfree86"
#    XkbModel    "pc101"
#    XkbLayout   "us"
#    XkbVariant  ""
#    XkbOptions  ""

   XkbKeycodes     "xfree86"
   XkbTypes        "default"
   XkbCompat       "default"
   XkbSymbols      "us(pc101)"
   XkbGeometry     "pc"
   XkbRules        "xfree86"
   XkbModel        "pc101"
    XkbLayout       "us"
EndSection

# **********************************************************************
# Pointer section
# **********************************************************************

Section "Pointer"
    Protocol    "PS/2"
    Device      "/dev/mouse"

# When using XQUEUE, comment out the above two lines, and uncomment
# the following line.

#    Protocol	"Xqueue"

# Baudrate and SampleRate are only for some Logitech mice

#    BaudRate	9600
#    SampleRate	150

# Emulate3Buttons is an option for 2-button Microsoft mice
# Emulate3Timeout is the timeout in milliseconds (default is 50ms)

#    Emulate3Buttons
#    Emulate3Timeout    50

# ChordMiddle is an option for some 3-button Logitech mice

#    ChordMiddle

EndSection


# **********************************************************************
# Monitor section
# **********************************************************************

# Any number of monitor sections may be present

Section "Monitor"

    Identifier  "HiNote Ultra II"
    VendorName  "DEC"
    ModelName   "TFT LCD"

# HorizSync is in kHz unless units are specified.
# HorizSync may be a comma separated list of discrete values, or a
# comma separated list of ranges of values.
# NOTE: THE VALUES HERE ARE EXAMPLES ONLY.  REFER TO YOUR MONITOR'S
# USER MANUAL FOR THE CORRECT NUMBERS.

    HorizSync   30-70

# VertRefresh is in Hz unless units are specified.
# VertRefresh may be a comma separated list of discrete values, or a
# comma separated list of ranges of values.
# NOTE: THE VALUES HERE ARE EXAMPLES ONLY.  REFER TO YOUR MONITOR'S
# USER MANUAL FOR THE CORRECT NUMBERS.

    VertRefresh 40-80

# Modes can be specified in two formats.  A compact one-line format, or
# a multi-line format.

# These two are equivalent

#    ModeLine "1024x768i" 45 1024 1048 1208 1264 768 776 784 817 Interlace

#    Mode "1024x768i"
#        DotClock	45
#        HTimings	1024 1048 1208 1264
#        VTimings	768 776 784 817
#        Flags		"Interlace"
#    EndMode

# This is a set of standard mode timings. Modes that are out of monitor
spec
# are automatically deleted by the server (provided the HorizSync and
# VertRefresh lines are correct), so there's no immediate need to
# delete mode timings (unless particular mode timings don't work on your
# monitor). With these modes, the best standard mode that your monitor
# and video card can support for a given resolution is automatically
# used.

Modeline "800x600" 40.00 800 824 872 960 600 600 601 625
Modeline "640x480" 25.18 640 664 760 800 480 491 493 525

EndSection


# **********************************************************************
# Graphics device section
# **********************************************************************

# Any number of graphics device sections may be present

Section "Device"
    Identifier        "Generic VGA"
    VendorName        "Unknown"
    BoardName "Unknown"
    Chipset   "generic"

#    VideoRam 256

#    Clocks   25.2 28.3

EndSection

# Device configured by Xconfigurator:

Section "Device"
    Identifier	"HiNote Ultra II"
    VendorName	"Chips & Technologies"
    BoardName	"CT65548"
    VideoRam    1024
# Option "noaccel"
# Option "no_bitblt"
# Option "xaa_no_color_exp"
# Option "xaa_benchmark"
# Option "hw_cursor"
# Option "mmio"
# Option "use_18bit_bus"
# Option "hw_clocks"
# Textclockfreq 25.175
# Option "nolinear"
# MemBase 0x03b00000
# Device section for C&T cards.
# Option "suspend_hack"
# Option "STN"
# Option "no_stretch"
# Option "no_center"
# Option "use_modeline"
# Option "fix_panel_size"
# videoram 512
    # Insert Clocks lines here if appropriate
EndSection


# **********************************************************************
# Screen sections
# **********************************************************************

# The Colour SVGA server

Section "Screen"
    Driver      "svga"
    # Use Device "Generic VGA" for Standard VGA 320x200x256
    #Device      "Generic VGA"
    Device	"HiNote Ultra II"
    Monitor	"HiNote Ultra II"
    Subsection "Display"
        Depth       8
        # Omit the Modes line for the "Generic VGA" device
        Modes      "800x600"
    EndSubsection
    SubSection "Display"
      Depth 16
      Modes "800x600"
    EndSubSection
EndSection

# The 16-color VGA server

Section "Screen"
    Driver      "vga16"
    Device      "HiNote Ultra II"
    Monitor     "HiNote Ultra II"
    Subsection "Display"
        Modes       "640x480" "800x600"
	Depth 4
    EndSubsection
EndSection

-------------------------------------------------------------

name of display:    :0.0
version number:    11.0
vendor string:    The XFree86 Project, Inc
vendor release number:    335
maximum request size:  4194300 bytes
motion buffer size:  256
bitmap unit, bit order, padding:    32, LSBFirst, 32
image byte order:    LSBFirst
number of supported pixmap formats:    2
supported pixmap formats:
    depth 1, bits_per_pixel 1, scanline_pad 32
    depth 8, bits_per_pixel 8, scanline_pad 32
keycode range:    minimum 8, maximum 134
focus:  window 0x4c0000e, revert to PointerRoot
number of extensions:    19
    BIG-REQUESTS
    DOUBLE-BUFFER
    DPMS
    LBX
    MIT-SCREEN-SAVER
    MIT-SHM
    MIT-SUNDRY-NONSTANDARD
    RECORD
    SECURITY
    SHAPE
    SYNC
    XC-APPGROUP
    XC-MISC
    XFree86-DGA
    XFree86-Misc
    XFree86-VidModeExtension
    XInputExtension
    XKEYBOARD
    XTEST
default screen number:    0
number of screens:    1

screen #0:
  dimensions:    800x600 pixels (271x203 millimeters)
  resolution:    75x75 dots per inch
  depths (2):    1, 8
  root window id:    0x2a
  depth of root window:    8 planes
  number of colormaps:    minimum 1, maximum 1
  default colormap:    0x21
  default number of colormap cells:    256
  preallocated pixels:    black 0, white 1
  options:    backing-store YES, save-unders YES
  largest cursor:    800x600
  current input event mask:    0x5c207f
    KeyPressMask             KeyReleaseMask           ButtonPressMask
    ButtonReleaseMask        EnterWindowMask          LeaveWindowMask
    PointerMotionMask        ButtonMotionMask         ResizeRedirectMask
    SubstructureNotifyMask   SubstructureRedirectMask PropertyChangeMask
  number of visuals:    6
  default visual id:  0x22
  visual:
    visual id:    0x22
    class:    PseudoColor
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    6 bits
  visual:
    visual id:    0x23
    class:    DirectColor
    depth:    8 planes
    available colormap entries:    8 per subfield
    red, green, bluemasks:    0x7, 0x38, 0xc0
    significant bits in color specification:    6 bits
  visual:
    visual id:    0x24
    class:    GrayScale
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    6 bits
  visual:
    visual id:    0x25
    class:    StaticColor
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x7, 0x38, 0xc0
    significant bits in color specification:    6 bits
  visual:
    visual id:    0x26
    class:    TrueColor
    depth:    8 planes
    available colormap entries:    8 per subfield
    red, green, blue masks:    0x7, 0x38, 0xc0
    significant bits in color specification:    6 bits
  visual:
    visual id:    0x27
    class:    StaticGray
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    6 bits
Comment 1 Leigh L. Klotz, Jr. 2000-05-09 12:34:59 EDT
Created attachment 233 [details]
XF86Config
Comment 2 Leigh L. Klotz, Jr. 2000-05-10 12:37:59 EDT
I've tried running in "fail safe" mode from the Gnome startup and cannot
reproduce the problem.  I inspected various gnome bug reports (previosly
I'd looked only at XFree86 bugs) and found 7645, which suggests loading
gnome-core-1.0.40.  I had overlooked gnome-core-1.0.40 because it is not
present on the RedHat errata page for 6.1 (though I do see "gnome-core"
mentioned in the comments section at the top of the page.) I sent mail
to sopwith@redhat.com who mentioned the gnome-core-1.0.40 update for 6.1
in bug 7645 and suggested that it be added to the RedHat errata page for
6.1 if appropriate.  In the meantime I am installing all gnome-* upgrades
from the RedHat 6.1 i386 site regardless of whether they are mentioned in
errata and will report back on the status.
Comment 3 Leigh L. Klotz, Jr. 2000-05-10 13:33:59 EDT
I've moved this to be a gnone-core bug and will mark it duplicate because
updating to gnome-core-1.0.54-2 appears to have fixed the problem.  I will re-
open if it happens again.

*** This bug has been marked as a duplicate of 7645 ***
Comment 4 Leigh L. Klotz, Jr. 2000-05-10 13:35:59 EDT
No, it still happens.  Sigh.
Comment 5 Preston Brown 2000-05-24 15:37:59 EDT
It would seem to be a chipset bug for which we have no real fix at the current
time.
Comment 6 Leigh L. Klotz, Jr. 2000-05-30 16:35:59 EDT
I now note that this bug is extremely close to bug 3678; may I assume that it
has to do with PS/2 support?

I have tried upgrading to RH 6.2 and now the mouse is frozen ab initio, though
the keyboard works fine.  Unfortunately, 6.2 does not work with two PCMCIA
cards, leaving me a choice between ethernet and CD ROM, so I will suspend work
on this issue until that other problem is resolved.
Comment 7 Leigh L. Klotz, Jr. 2000-08-09 02:25:35 EDT
I assume at this point it is flakey or unsupported hardware as I have been unable to reproduce it on other systems.
Thank you for your patience.

Note You need to log in before you can comment on or make changes to this bug.