Bug 113313 - Updating alchemist without updating python to 2.3 fails cups
Summary: Updating alchemist without updating python to 2.3 fails cups
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: python
Version: 1.0
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Mihai Ibanescu
QA Contact: Brock Organ
: 117501 (view as bug list)
Depends On:
TreeView+ depends on / blocked
Reported: 2004-01-12 14:24 UTC by Moritz Barsnick
Modified: 2007-04-18 17:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2004-07-12 12:44:27 UTC

Attachments (Terms of Use)

Description Moritz Barsnick 2004-01-12 14:24:51 UTC
Description of problem:
Due to missing dependencies, it is possible to update alchemist from 
older versions (e.g. the one delivered with FC test3) to newer 
versions without updating python-2.2 to python-2.3. Yet its files,
now located in /usr/lib/python2.3/site-packages, are not found by 
python-2.2. Most visible effect: The cups init script fails. 
(Exporting this patch as PYTHONPATH or whatever sort of fixes this,
but with the warning that alchemist's API is newer.)

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install Fedora Core Test 3.
2. Update alchemist.
3. Reboot
Actual results:
cups init script fails with missing pyalchemist.

Expected results:
Boot nicely.

Additional info:
This is a very generic python-2.2 vs -2.3 problem. I wonder why it 
doesn't bug many other apps!? The other way around -- python-2.2 
libraries in a python-2.3 environment -- seems to work fine, 
otherwise 4Suite would've had to be rebuilt as well.

In this case, I would have recommended a "Requires: python >= 2.3" 
for all packages which deposit libraries in /usr/lib/python2.3/.

Or is there another generic way to handle this?

Comment 1 Tim Waugh 2004-01-12 14:50:40 UTC
But 'Requires: python >= 2.3' would be incorrect, since 2.4 (say)
would give the same failure.

This needs to be solved in the python package and is similar to the
python-abi problem.

Comment 2 Tim Waugh 2004-01-22 14:47:26 UTC
Let's state it explicitly, since I can't find it anywhere else in

Python needs to provide 'python-abi = 2.3', and packages that provide
Python modules need to require that symbol.

Comment 3 Mihai Ibanescu 2004-02-12 16:49:14 UTC
As of Fedora Core 1, python does provide python-abi = 2.3

Comment 4 Tim Waugh 2004-03-04 19:00:15 UTC
*** Bug 117501 has been marked as a duplicate of this bug. ***

Comment 5 Moritz Barsnick 2004-07-12 12:44:27 UTC
I can't reproduce, since I don't have a system with that version 
clash to fall back to anymore. The dependency I had requested seems 
to be fulfilled, so I shall just close this, okay?

Note You need to log in before you can comment on or make changes to this bug.