Bug 113333 - glibc-2.3.2-101.4
Summary: glibc-2.3.2-101.4
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
(Show other bugs)
Version: 1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-12 19:55 UTC by Jon Smirl
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-28 09:29:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jon Smirl 2004-01-12 19:55:26 UTC
I just bought this down via apt-get.

After prelinking things like mozilla and gaim got network errors.
ftp was still ok. Undoing prelink fixed the problem.

Comment 1 Jakub Jelinek 2004-01-12 20:57:08 UTC
Have you kept the prelinked binaries and libraries they depend on,
or are you able to reproduce it by prelinking again?

Comment 2 Jon Smirl 2004-01-13 01:05:00 UTC
I prelinked again. This time Mozilla is ok, but gaim is still not
working. It gets "unexpected network error".

prelink/unprelink is about a one hour process on my machine.


Comment 3 Jon Smirl 2004-01-13 01:08:26 UTC
I also believe I am getting a lot more "undefined non-weak symbols"
that I used too.

These have undefined symbols:
/usr/sbin/prelink: Warning: /usr/lib/libFLAC.so.4.1.2 has undefined
non-weak symbols
/usr/sbin/prelink: Warning: /lib/libdb-4.0.so has undefined non-weak
symbols
/usr/sbin/prelink: Warning: /usr/lib/libgmodule-1.2.so.0.0.10 has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libgtk-1.2.so.0.9.1 has undefined
non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libgdk-1.2.so.0.9.1 has undefined
non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libgimpui-1.2.so.0.0.5 has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libgimp-1.2.so.0.0.5 has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/htdig/libhtnet-3.2.0.so has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/htdig/libcommon-3.2.0.so has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/htdig/libhtword-3.2.0.so has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/htdig/libht-3.2.0.so has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/X11R6/lib/libGLU.so.1.3 has undefined
non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libpropertyeditor.so.0.0.0 has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libgdk_imlib.so.1.9.13 has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libORBit.so.0.5.17 has undefined
non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libgnorba.so.27.1.8 has undefined
non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libgnomeui.so.32.14.1 has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libgnome.so.32.4.3 has undefined
non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libkscreensaver.so.4.2.0 has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libkalarmd.so.0.0.0 has undefined
non-weak symbols
/usr/sbin/prelink: Warning: /lib/liblvm-10.so.1.0 has undefined
non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libpisync.so.0.0.1 has undefined
non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libvte.so.4.1.1 has undefined
non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/graphviz/libgraph.so.0.0.0 has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libgthread-1.2.so.0.0.10 has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/graphviz/libexpr.so.0.0.0 has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/graphviz/libagraph.so.0.0.0 has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libapt-pkg-libc6.3-5.so.0.1.0 has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libSDL-1.2.so.0.0.5 has undefined
non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libpostproc.so.0.0.1 has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/graphviz/libpathplan.so.0.0.0 has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libkdevcatalog.so.0.0.0 has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libkdevcppparser.so.0.0.0 has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libgnorbagtk.so.0.0.0 has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libnetsnmp.so.5.1.0 has undefined
non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libefs.so.1 has undefined
non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libuser.so.1.1.1 has undefined
non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libgal.so.23.0.0 has undefined
non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libxdelta.so.2 has undefined
non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libgnomecanvaspixbuf.so.1.0.0 has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libglade-gnome.so.0.4.2 has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libgconf-gtk-1.so.1.0.0 has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libcroco.so.1.0.0 has undefined
non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libcrseleng.so.1.0.0 has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libcrlayeng.so.1.0.0 has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/dia/libdia.so has undefined
non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libcupsimage.so.2 has undefined
non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libostyle.so.0 has undefined
non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libospgrove.so.0 has undefined
non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libogrove.so.0 has undefined
non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libfaad.so.0.0.0 has undefined
non-weak symbols
/usr/sbin/prelink: Warning: /usr/bin/mplayer has undefined non-weak
symbols
/usr/sbin/prelink: Warning: /usr/X11R6/lib/libXfont.so.1.4 has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libqtnotfier.so.3.1.7 has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/htdig/libfuzzy-3.2.0.so has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /opt/kde3/lib/libkscreensaver.so.4.2.0 has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libkompareinterface.so.0.0.0 has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libkommanderwidgets.so.0.0.0 has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libOggFLAC.so.1 has undefined
non-weak symbols
/usr/sbin/prelink: Warning: /opt/kde3/lib/libpropertyeditor.so.0.0.0
has undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libxsldbg.so.3.1.7 has undefined
non-weak symbols
/usr/sbin/prelink: Warning: /opt/kde3/lib/libkdevcppparser.so.0.0.0
has undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/bin/mencoder has undefined non-weak
symbols
/usr/sbin/prelink: Warning: /usr/lib/libkpilot.so.0.0.0 has undefined
non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libgnome-mag.so.1.0.3 has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /opt/kde3/lib/libkdevcatalog.so.0.0.0 has
undefined non-weak symbols
/usr/sbin/prelink: Warning: /usr/lib/libpisock++.so.0 has undefined
non-weak symbols
/usr/sbin/prelink: Warning:
/usr/X11R6/LessTif/Motif1.2/lib/libMrm.so.1.0.2 has undefined non-weak
symbols
/usr/sbin/prelink: Warning: /usr/lib/libkdgantt.so.0.0.0 has undefined
non-weak symbols


Comment 4 Jon Smirl 2004-01-13 01:38:47 UTC
I think I have everything working now. I did a complete clean prelink.
The failure appears to be somewhere in the incremental prelink process. 

The problem with gaim is that the new version 75-1 on freshrpms is
broken. Backing off to the fedora 74-5 version fixes it.

I still get all of the undefined non-weak symbols from prelink

Comment 5 Ulrich Drepper 2004-09-28 09:29:19 UTC
I'm closing this bug since it has only been the result of not
prelinking again.

Re the prelink warnings: you can file bugs for each of the packages. 
prelink is right in any case, it's the packages which are broken.  If
you file bugs make sure there are none covering the error already.


Note You need to log in before you can comment on or make changes to this bug.