Bug 113358 - Installer fails on FTP upgrade attempt
Summary: Installer fails on FTP upgrade attempt
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 1.0
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-13 02:51 UTC by Jim Cornette
Modified: 2007-04-18 17:01 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-28 03:14:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda dump from /root directory (649.23 KB, text/plain)
2004-01-13 03:00 UTC, Jim Cornette
no flags Details
up2date path to partial upgrade, before up2date halted (3.61 KB, text/plain)
2004-01-13 23:40 UTC, Jim Cornette
no flags Details
dump from ftp upgrade 1/17/04 (645.28 KB, text/plain)
2004-01-18 00:57 UTC, Jim Cornette
no flags Details
dump from ftp upgrade 01-18-04 (645.85 KB, text/plain)
2004-01-18 16:37 UTC, Jim Cornette
no flags Details
Dump from another install - fedora-core 1 to ftp upgrade (665.98 KB, text/plain)
2004-01-18 18:17 UTC, Jim Cornette
no flags Details
screenshot from install attempt (656.52 KB, image/jpg)
2004-01-24 23:54 UTC, Jim Cornette
no flags Details
first screen error (628.15 KB, image/jpg)
2004-01-24 23:55 UTC, Jim Cornette
no flags Details
screen 3 output (645.77 KB, image/jpg)
2004-01-24 23:56 UTC, Jim Cornette
no flags Details
screen 3 with glare in another place (624.60 KB, image/jpg)
2004-01-24 23:58 UTC, Jim Cornette
no flags Details
strange output for screen 2 for directories and symlinks to directories (635.38 KB, image/jpg)
2004-01-25 03:41 UTC, Jim Cornette
no flags Details

Description Jim Cornette 2004-01-13 02:51:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
When trying to do an FTP upgrade using the boot.iso dated 01-12-04, I
get a dump to root and an option to save to floppy. I received a
similar error with an FTP install with the boot.iso dated 01-11-04
recently. An error as described was also encountered.


Version-Release number of selected component (if applicable):
anaconda-9.3-0.20040111000

How reproducible:
Always

Steps to Reproduce:
1. Download and burn boot.iso for 01-12-04
2. Load disk in bootable CD-Reader and boot computer
3. complete steps to get to the FTP selection
4. Enter FTP site and path to directory
5. Answer questions needed to do installation or upgrade
6. Select programs desired and wait for anaconda to complete steps.
7. Note bug pop-up and save dump to floppy
8. Save error to floppy.
9. reboot system, no damage, anaconda error also in /root directory   

Actual Results:  Anaconda prompted for the user to save the error to
floppy and afet the information was saved, system halted in a safe state.

Expected Results:  The installer would have went through all of the
needed steps and come up with a working upgraded system. Errors with
the instable mix of packages and erratic dependacies is too great to
do a rawhide install currently.

Additional info:

I have submitted an error report for the net-snmp package not meeting
the current rpmlib requirements. The developer is working on meeting
the current rpmlib requirement.

Comment 1 Jim Cornette 2004-01-13 03:00:03 UTC
Created attachment 96924 [details]
Anaconda dump from /root directory

I hope this helps.

Comment 2 Jeremy Katz 2004-01-13 20:59:05 UTC
This looks like another skew in rpmlib API that breaks things for me.
 Hooray :/

Will look into once I get test hardware back up and running (just moved)

Comment 3 Jim Cornette 2004-01-13 23:40:25 UTC
Created attachment 96957 [details]
up2date path to partial upgrade, before up2date halted

Comment 4 Jim Cornette 2004-01-18 00:57:17 UTC
Created attachment 97078 [details]
dump from ftp upgrade 1/17/04

Is this caused by the mix of packages being dis-located?  I had an error
regarding a package named redhat-logviewer not being in the directory.

The ftp upgrade failed with this dump.

Thanks,

Jim

Comment 5 Jim Cornette 2004-01-18 16:37:16 UTC
Created attachment 97084 [details]
dump from ftp upgrade 01-18-04

There was a mention about the noarch packages from development not being
mirrored by some of the mirrors. Most of my conflicts seem to be with
installing the noarch packages. Something about a s390 directory.

Comment 6 Jim Cornette 2004-01-18 18:17:54 UTC
Created attachment 97085 [details]
Dump from another install - fedora-core 1 to ftp upgrade

This attachment is from a system that was updated to fedora core 1, then ftp
install upgrade was attempted.
The 01-18-04 dump was from a development only FTP install that went well and
was attempted to bring it up to current level.

Comment 7 Jeremy Katz 2004-01-22 22:21:41 UTC
I pretty much had all I needed after the first traceback, but thanks
for  all of them :-)

Fixed in CVS

Comment 8 Jim Cornette 2004-01-23 01:07:12 UTC
I noted a problem with getting updates that related to noarch rpms
giving a 550 error for not being able to change directories. I tried
the ftp install fro the same mirror that I get updates from.

Sorry for the excessive traces.

Comment 9 Jim Cornette 2004-01-24 23:54:44 UTC
Created attachment 97241 [details]
screenshot from install attempt

Comment 10 Jim Cornette 2004-01-24 23:55:38 UTC
Created attachment 97242 [details]
first screen error

Comment 11 Jim Cornette 2004-01-24 23:56:33 UTC
Created attachment 97243 [details]
screen 3 output

Comment 12 Jim Cornette 2004-01-24 23:58:03 UTC
Created attachment 97244 [details]
screen 3 with glare in another place

Comment 13 Jim Cornette 2004-01-25 03:41:35 UTC
Created attachment 97245 [details]
strange output for screen 2 for directories and symlinks to directories

Comment 14 Jim Cornette 2004-01-28 03:10:44 UTC
Screen 2 looked fine during the upgrade. No strange characters
present. I believe that it was black and white, but it worked. no
major distraction.


Note You need to log in before you can comment on or make changes to this bug.