Bug 11336 - Sort
Summary: Sort
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 4.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-09 19:45 UTC by tomw1$
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-22 14:53:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description tomw1$ 2000-05-09 19:45:53 UTC
The sort command that works on UNIX will not on Linux 6.2.
If I create indentical files in UNIX and Linux and run the sort command
this is what happens:
         UNIX                                  Linux
  vi filename                               vi filename
  abc1                                      abc1
  a bc2                                     a bc2
  abc3                                      abc3

 close files
 sort filename                              sort filename
  a bc2                                     abc1
  abc1                                      a bc2
  abc3                                      abc3

Sort in UNIX moves the line of text that contains a space (a bc2) to
the top while in Linux it does not change position.  We have a program
that will not work in Linux because of this difference in operation.

Comment 1 Jeff Johnson 2000-05-11 16:39:59 UTC
This is almost certainly a glibc locale problem, so I'm changing the component
...

Comment 2 Cristian Gafton 2000-05-22 14:53:59 UTC
assign to jakub

Comment 3 Preston Brown 2000-07-05 18:55:49 UTC
fixed by textutils errata

Comment 4 David Lawrence 2000-07-05 19:30:24 UTC
The updated textutils package depending on your platform are located:

i386:
ftp://updates.redhat.com/6.2/i386/textutils-2.0e-6.i386.rpm

alpha:
ftp://updates.redhat.com/6.2/alpha/textutils-2.0e-6.alpha.rpm

sparc:
ftp://updates.redhat.com/6.2/sparc/textutils-2.0e-6.sparc.rpm

sources:
ftp://updates.redhat.com/6.2/SRPMS/textutils-2.0e-6.src.rpm

Install the new update by running:

rpm -Fvh [filename]


Note You need to log in before you can comment on or make changes to this bug.