Bug 113396 - Procmail not writing to files 49 megs or larger
Procmail not writing to files 49 megs or larger
Status: CLOSED DUPLICATE of bug 88214
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: postfix (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-13 10:32 EST by Joshua Jensen
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Jensen 2004-01-13 10:32:38 EST
Description of problem:

I've seen this twice now, on two different 49 meg mail files:

procmail: Opening "spam"
procmail: Acquiring kernel-lock
procmail: Error while writing to "spam"
procmail: Truncated file to former size
procmail: Unlocking "spam.lock"

Whenever I see this, file spam is always size 50056.

Contrast this to another write to an email file that is smaller:

procmail: Opening "fedora-list"
procmail: Acquiring kernel-lock
procmail: Notified comsat: "joshua@5921064:/home/joshua/mail/fedora-list"
From fedora-list-admin@redhat.com  Tue Jan 13 10:30:18 2004
 Subject: Enable ACPI and Laptop under Fedora Core 1
  Folder: fedora-list                                                   


Dmesg and /var/log/messages not showing anything interesting... this
doesn't seem to be a system or resource failure... just procmail 

Version-Release number of selected component (if applicable):

RHEL3 AS with all updates

How reproducible:

Creat a valid, non-corrupt email file with 48 megs or so of email...
then watch procmail choke when it gets up to 49 to 50 megs in size.
Comment 1 Jens Petersen 2004-01-20 06:47:23 EST
Presumably you're using postfix as your mta?

postfix defaults to a maximum mbox size of 50MB.
Comment 2 John Dennis 2004-01-20 09:46:59 EST
This is a duplicate of bug 88214. Postfix has a mailbox size limit
which defaults to 50 MB, you can override this parameter, please see
bug 88214   for how to do this.  

*** This bug has been marked as a duplicate of 88214 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:00:44 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.
Comment 4 Milan Kerslager 2006-09-06 11:09:24 EDT
FYI: parametr "mailbox_size_limit" in local.cf.

Note You need to log in before you can comment on or make changes to this bug.