Bug 11341 - RPM won't upgrade fortune-mod or xloadimage
RPM won't upgrade fortune-mod or xloadimage
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-09 21:32 EDT by redhat
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-10 13:51:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description redhat 2000-05-09 21:32:32 EDT
Upgraded from 6.0 to 6.2. Rpm simply refuses to upgrade or install
either fortune-mod or xloadimage (the other packages seemed to
upgrade fine).

(I removed the old version thinking it might help install the
new one).
[root@localhost /tmp]# rpm -ivh fortune-mod-1.0-11.i386.rpm
Segmentation fault

[root@localhost /tmp]# strace rpm -ivh fortune-mod-1.0-11.i386.rpm
execve("/bin/rpm", ["rpm", "-ivh", "fortune-mod-1.0-11.i386.rpm"], [/* 24
vars */]) = 0
fcntl(0, F_GETFD)                       = 0
fcntl(1, F_GETFD)                       = 0
fcntl(2, F_GETFD)                       = 0
personality(PER_LINUX)                  = 0
geteuid()                               = 0
getuid()                                = 0
getegid()                               = 0
getgid()                                = 0
brk(0)                                  = 0x813438c
brk(0x81343ac)                          = 0x81343ac
brk(0x8135000)                          = 0x8135000
getpid()                                = 1179
open("/usr/lib/rpm/rpmpopt", O_RDONLY)  = 3
lseek(3, 0, SEEK_END)                   = 3683
lseek(3, 0, SEEK_SET)                   = 0
read(3, "#\n# This file *should not be mod"..., 3683) = 3683
close(3)                                = 0
brk(0x8136000)                          = 0x8136000
open("/etc/popt", O_RDONLY)             = -1 ENOENT (No such file or
directory)
getuid()                                = 0
geteuid()                               = 0
open("/root/.popt", O_RDONLY)           = -1 ENOENT (No such file or
directory)
uname({sys="Linux", node="localhost.localdomain.com", ...}) = 0
open("/usr/lib/rpm/rpmrc", O_RDONLY)    = 3
brk(0x8137000)                          = 0x8137000
gettimeofday({957921429, 717406}, NULL) = 0
fstat(3, {st_mode=S_IFREG|0644, st_size=7716, ...}) = 0
old_mmap(NULL, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1,
0) = 0x40000000
select(4, [3], NULL, NULL, {1, 0})      = 1 (in [3], left {1, 0})
gettimeofday({957921429, 718179}, NULL) = 0
read(3, "# $Id: rpmrc.in,v 2.18 2000/02/2"..., 8192) = 7716
gettimeofday({957921429, 718584}, NULL) = 0
select(4, [3], NULL, NULL, {1, 0})      = 1 (in [3], left {1, 0})
gettimeofday({957921429, 718945}, NULL) = 0
read(3, "", 476)                        = 0
gettimeofday({957921429, 719111}, NULL) = 0
gettimeofday({957921429, 719263}, NULL) = 0
close(3)                                = 0
gettimeofday({957921429, 719428}, NULL) = 0
gettimeofday({957921429, 719517}, NULL) = 0
gettimeofday({957921429, 719599}, NULL) = 0
munmap(0x40000000, 8192)                = 0
brk(0x8138000)                          = 0x8138000
brk(0x8139000)                          = 0x8139000
brk(0x813a000)                          = 0x813a000
open("/etc/rpmrc", O_RDONLY)            = -1 ENOENT (No such file or
directory)
open("/root/.rpmrc", O_RDONLY)          = -1 ENOENT (No such file or
directory)
open("/usr/lib/rpm/macros", O_RDONLY)   = 3
gettimeofday({957921429, 722059}, NULL) = 0
old_mmap(NULL, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1,
0) = 0x40000000
select(4, [3], NULL, NULL, {1, 0})      = 1 (in [3], left {1, 0})
gettimeofday({957921429, 722682}, NULL) = 0
read(3, "# $Id: macros.in,v 1.46 2000/02/"..., 8192) = 8192
gettimeofday({957921429, 722967}, NULL) = 0
brk(0x813b000)                          = 0x813b000
brk(0x813c000)                          = 0x813c000
select(4, [3], NULL, NULL, {1, 0})      = 1 (in [3], left {1, 0})
gettimeofday({957921429, 728157}, NULL) = 0
read(3, "dy}\n%__spec_build_post\t%{___buil"..., 8192) = 8192
gettimeofday({957921429, 728410}, NULL) = 0
brk(0x813d000)                          = 0x813d000
brk(0x813e000)                          = 0x813e000
select(4, [3], NULL, NULL, {1, 0})      = 1 (in [3], left {1, 0})
gettimeofday({957921429, 736278}, NULL) = 0
read(3, "itearch`\"; echo $installsitearch"..., 8192) = 767
gettimeofday({957921429, 736475}, NULL) = 0
select(4, [3], NULL, NULL, {1, 0})      = 1 (in [3], left {1, 0})
gettimeofday({957921429, 736808}, NULL) = 0
read(3, "", 7425)                       = 0
gettimeofday({957921429, 736979}, NULL) = 0
select(4, [3], NULL, NULL, {1, 0})      = 1 (in [3], left {1, 0})
gettimeofday({957921429, 738200}, NULL) = 0
read(3, "", 8192)                       = 0
gettimeofday({957921429, 738380}, NULL) = 0
gettimeofday({957921429, 738477}, NULL) = 0
close(3)                                = 0
gettimeofday({957921429, 738640}, NULL) = 0
gettimeofday({957921429, 738728}, NULL) = 0
gettimeofday({957921429, 738810}, NULL) = 0
munmap(0x40000000, 8192)                = 0
open("/usr/lib/rpm/i686-linux/macros", O_RDONLY) = -1 ENOENT (No such file
or directory)
open("/etc/rpm/macros.specspo", O_RDONLY) = -1 ENOENT (No such file or
directory)
open("/etc/rpm/macros", O_RDONLY)       = -1 ENOENT (No such file or
directory)
open("/etc/rpm/i686-linux/macros", O_RDONLY) = -1 ENOENT (No such file or
directory)
open("/root/.rpmmacros", O_RDONLY)      = -1 ENOENT (No such file or
directory)
open("fortune-mod-1.0-11.i386.rpm", O_RDONLY) = 3
gettimeofday({957921429, 740573}, NULL) = 0
fstat(3, {st_mode=S_IFREG|0644, st_size=1035820, ...}) = 0
select(4, [3], NULL, NULL, {1, 0})      = 1 (in [3], left {1, 0})
gettimeofday({957921429, 741071}, NULL) = 0
read(3, "\355\253\356\333\3\0\0\0\0\1fortune-mod-1.0-11\0\0\0\0"..., 96) =
96
gettimeofday({957921429, 741299}, NULL) = 0
select(4, [3], NULL, NULL, {1, 0})      = 1 (in [3], left {1, 0})
gettimeofday({957921429, 741808}, NULL) = 0
read(3, "\216\255\350\1\0\0\0\0\0\0\0\3\0\0\0T", 16) = 16
gettimeofday({957921429, 742021}, NULL) = 0
select(4, [3], NULL, NULL, {1, 0})      = 1 (in [3], left {1, 0})
gettimeofday({957921429, 742356}, NULL) = 0
read(3, "\0\0\3\350\0\0\0\4\0\0\0\0\0\0\0\1\0\0\3\354\0\0\0\7\0"..., 132) =
132
gettimeofday({957921429, 742599}, NULL) = 0
fstat(3, {st_mode=S_IFREG|0644, st_size=1035820, ...}) = 0
select(4, [3], NULL, NULL, {1, 0})      = 1 (in [3], left {1, 0})
gettimeofday({957921429, 743316}, NULL) = 0
read(3, "\0\0\0\0", 4)                  = 4
gettimeofday({957921429, 743513}, NULL) = 0
select(4, [3], NULL, NULL, {1, 0})      = 1 (in [3], left {1, 0})
gettimeofday({957921429, 743854}, NULL) = 0
read(3, "\216\255\350\1\0\0\0\0\0\0\0)\0\0&\264", 16) = 16
gettimeofday({957921429, 744066}, NULL) = 0
brk(0x8141000)                          = 0x8141000
select(4, [3], NULL, NULL, {1, 0})      = 1 (in [3], left {1, 0})
gettimeofday({957921429, 744522}, NULL) = 0
read(3, "\0\0\0d\0\0\0\10\0\0\0\0\0\0\0\1\0\0\3\350\0\0\0\6\0\0"..., 10564)
= 10564
gettimeofday({957921429, 744880}, NULL) = 0
brk(0x8142000)                          = 0x8142000
brk(0x8143000)                          = 0x8143000
--- SIGSEGV (Segmentation fault) ---
+++ killed by SIGSEGV +++


And for the second one:

[root@localhost /tmp]# rpm -q rpm
rpm-3.0.4-0.48

[root@localhost /tmp]# rpm -q xloadimage
xloadimage-4.1-12

[root@localhost /tmp]# rpm -Fvh xloadimage-4.1-13.i386.rpm
error: file xloadimage-4.1-13.i386.rpm requires a newer version of RPM

The strace output takes over 32k so I will omit it, but it does
seem to complain about not finding rpmrc files (the rpm package
doesn't include any, and didn't create any).

Thank you for your help.
Comment 1 SB 2000-05-10 07:46:59 EDT
Is this an upgrade from CD or downloaded packages?  Have you tried upgrading to a

newer version of rpm? Try reinstalling you rpm package and if their are any

corrupt rpm config files hopefully they will be fixed.  Also do a rpm -K *.rpm to

make sure the rpms aren't corrupt, even if you got it on CD.  heh I like GDB

output better as I know what function it's dying in ;)



-Stan Bubrouski
Comment 2 Jeff Johnson 2000-05-10 13:51:59 EDT
I can't reproduce either of these segfaults. That usually means that the
segfault is due to bad data from the database, and a "rpm --rebuilddb"
will fix. Please reopen this bug if "rpm --rebuilddb" does not fix your
problem.

Note You need to log in before you can comment on or make changes to this bug.