Bug 1134333 - missing dependency oxygen theme
Summary: missing dependency oxygen theme
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cantata
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-27 10:11 UTC by Frederik
Modified: 2014-09-09 22:20 UTC (History)
3 users (show)

Fixed In Version: cantata-1.4.1-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-09 22:17:23 UTC


Attachments (Terms of Use)

Description Frederik 2014-08-27 10:11:26 UTC
Description of problem:
cantata installs but fails to run, missing the "oxygen-icon-theme"

Version-Release number of selected component (if applicable):


How reproducible:
always


Steps to Reproduce:
1. Install Fedora with default settings and components (Gnome 3)
2. sudo dnf install cantata
3. start cantata

Actual results:
cantata dosn't start correctly

Expected results:
cantata starts correctly

Additional info:
easily solved by: sudo dnf install oxygen-icon-theme

oxygen-icon-theme should be in the dependencies

Comment 1 Rex Dieter 2014-08-27 12:30:06 UTC
Are you sure the reason it isn't starting is due simply to missing icons?

Can you provide a backtrace?

Comment 2 Rex Dieter 2014-08-27 12:37:31 UTC
nvm, I can reproduce it, we may as well add a dep somewhere, either oxygen-icon-theme or kde-runtime

Comment 3 Frederik 2014-08-27 13:01:58 UTC
took me a while to get all the stuff to create the backtrace...

since it runs fine with the theme (aka without the runtime) I think just the theme should be added as a dependancy

Comment 4 Rex Dieter 2014-08-27 16:13:41 UTC
I've managed to fix the crash, but there are still missing icons, so yeah, we'll add the dependency temporarily at least, until we can find some better fallback icons to use

Comment 5 Fedora Update System 2014-08-27 17:52:38 UTC
cantata-1.4.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/cantata-1.4.1-1.fc20

Comment 6 Fedora Update System 2014-08-27 17:53:19 UTC
cantata-1.4.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/cantata-1.4.1-1.fc19

Comment 7 lnie 2014-08-28 02:52:49 UTC
cantata-1.4.1-1.fc20 works

Comment 8 Fedora Update System 2014-08-28 15:29:16 UTC
Package cantata-1.4.1-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cantata-1.4.1-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-9806/cantata-1.4.1-1.fc20
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2014-09-09 22:17:23 UTC
cantata-1.4.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2014-09-09 22:20:39 UTC
cantata-1.4.1-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.