Bug 113434 - cluster member whose IP changes underneath it reboots constantly
cluster member whose IP changes underneath it reboots constantly
Status: CLOSED CURRENTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: clumanager (Show other bugs)
3
i386 Linux
low Severity high
: ---
: ---
Assigned To: Lon Hohberger
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-13 16:27 EST by Suzanne Hillman
Modified: 2009-04-16 16:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-05 16:10:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Suzanne Hillman 2004-01-13 16:27:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1)
Gecko/20030225

Description of problem:
If a cluster member has its IP changed out from under it (in this
case, it was set to DHCP and the cable was put into a different
subnet), it will get into a constantly rebooting state, making it
nearly impossible to debug.

This is not going to happen at *all* often, so making it low priority,
but it's highly unpleasant when it does happen, thus high severity.

Version-Release number of selected component (if applicable):
clumanager-1.2.7-1

How reproducible:
Didn't try

Steps to Reproduce:
1. Set up a cluster with machines using DHCP to get their IP addresses
2. Start the cluster
3. Move one of the member's ethernet cables to another subnet
    

Actual Results:  The machine in question was constantly rebooting, at
a rate too rapid to debug the problem. Could have told it to go to a
run level at which the cluster did not run, but only if one has
console access.

Expected Results:  It should have realized that it couldn't talk to
the cluster, and just stopped the cluster and waited. (Not sure how
feasible this is, though, since it does make sense for it to be
continually leaving the cluster, and rebooting is how that is forced)

Additional info:

I did not have a tie-breaker IP set up, but don't think it would have
helped.
Comment 1 Lon Hohberger 2004-01-13 16:37:51 EST
Rebooting is fine.. once.  Rebooting all the time... well... that's not ;)
Comment 2 Lon Hohberger 2004-02-09 11:13:48 EST
May be fixed by the fix incorporated in:

http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=114653

Will check.
Comment 3 Lon Hohberger 2007-12-21 10:10:32 EST
Fixing product name.  Clumanager on RHEL3 was part of RHCS3, not RHEL3

Note You need to log in before you can comment on or make changes to this bug.