Bug 113439 - korganizer fails with traceback
korganizer fails with traceback
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kdepim (Show other bugs)
3.0
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-13 17:37 EST by Ben Levenson
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-21 16:06:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Levenson 2004-01-13 17:37:15 EST
Description of problem: 
launch korganizer, get traceback: 
 
(no debugging symbols found)...Using host libthread_db library 
"/lib64/tls/libthread_db.so.1". 
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...[Thread 
debugging using libthread_db enabled] 
[New Thread 182894273632 (LWP 28077)] 
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols 
found)...0x0000002a98553766 in waitpid () from 
/lib64/tls/libpthread.so.0 
#0  0x0000002a98553766 in waitpid () from /lib64/tls/libpthread.so.0 
#1  0x0000002a96f14d0b in KCrash::defaultCrashHandler(int) () 
   from /usr/lib64/libkdecore.so.4 
#2  <signal handler called> 
#3  0x0000002a98e57572 in strcmp () from /lib64/tls/libc.so.6 
#4  0x0000002a9603de5a in icalparameter_new_from_value_string () 
   from /usr/lib64/libkcal.so.2 
#5  0x0000002a96047338 in icalparser_add_line () from 
/usr/lib64/libkcal.so.2 
#6  0x0000002a960470c9 in icalparser_parse () from 
/usr/lib64/libkcal.so.2 
#7  0x0000002a96047941 in icalparser_parse_string () 
   from /usr/lib64/libkcal.so.2 
#8  0x0000002a96042869 in icalcomponent_new_from_string () 
   from /usr/lib64/libkcal.so.2 
#9  0x0000002a9602ec39 in 
KCal::ICalFormat::fromString(KCal::Calendar*, QString const&) () 
from /usr/lib64/libkcal.so.2 
#10 0x0000002a9602e9b1 in KCal::ICalFormat::load(KCal::Calendar*, 
QString const&) () from /usr/lib64/libkcal.so.2 
#11 0x0000002a9603a164 in KCal::FileStorage::load() () 
   from /usr/lib64/libkcal.so.2 
#12 0x0000002a9573eb8a in CalendarView::openCalendar(QString, bool) 
() 
   from /usr/lib64/libkorganizer.so.1 
#13 0x0000002a9576971f in KOrganizer::openURL(KURL const&, bool) () 
   from /usr/lib64/libkorganizer.so.1 
#14 0x0000002a957626da in KOrganizerApp::processCalendar(KURL 
const&, int) () 
   from /usr/lib64/libkorganizer.so.1 
#15 0x0000002a9576239c in KOrganizerApp::newInstance() () 
   from /usr/lib64/libkorganizer.so.1 
#16 0x0000002a96f2cc64 in KUniqueApplication::processDelayed() () 
   from /usr/lib64/libkdecore.so.4 
#17 0x0000002a96f2cf66 in KUniqueApplication::qt_invoke(int, 
QUObject*) () 
   from /usr/lib64/libkdecore.so.4 
#18 0x0000002a95761551 in KOrganizerApp::qt_invoke(int, QUObject*) 
() 
   from /usr/lib64/libkorganizer.so.1 
#19 0x0000002a9798a7a3 in QObject::activate_signal(QConnectionList*, 
QUObject*) 
    () from /usr/lib64/qt-3.1/lib/libqt-mt.so.3 
#20 0x0000002a97c01aa2 in QSignal::signal(QVariant const&) () 
   from /usr/lib64/qt-3.1/lib/libqt-mt.so.3 
#21 0x0000002a979a0324 in QSignal::activate() () 
   from /usr/lib64/qt-3.1/lib/libqt-mt.so.3 
#22 0x0000002a979a6088 in QSingleShotTimer::event(QEvent*) () 
   from /usr/lib64/qt-3.1/lib/libqt-mt.so.3 
#23 0x0000002a979379a3 in QApplication::internalNotify(QObject*, 
QEvent*) () 
   from /usr/lib64/qt-3.1/lib/libqt-mt.so.3 
#24 0x0000002a979373c1 in QApplication::notify(QObject*, QEvent*) () 
   from /usr/lib64/qt-3.1/lib/libqt-mt.so.3 
#25 0x0000002a96eb3095 in KApplication::notify(QObject*, QEvent*) () 
   from /usr/lib64/libkdecore.so.4 
#26 0x0000002a97916f5d in QEventLoop::activateTimers() () 
   from /usr/lib64/qt-3.1/lib/libqt-mt.so.3 
#27 0x0000002a978f895f in QEventLoop::processEvents(unsigned) () 
   from /usr/lib64/qt-3.1/lib/libqt-mt.so.3 
#28 0x0000002a97948d2f in QEventLoop::enterLoop() () 
   from /usr/lib64/qt-3.1/lib/libqt-mt.so.3 
#29 0x0000002a97948bf2 in QEventLoop::exec() () 
   from /usr/lib64/qt-3.1/lib/libqt-mt.so.3 
#30 0x0000002a97937b25 in QApplication::exec() () 
   from /usr/lib64/qt-3.1/lib/libqt-mt.so.3 
#31 0x0000002a9573ab8d in main () from /usr/lib64/libkorganizer.so.1 
#32 0x0000002a98df8181 in __libc_start_main () from 
/lib64/tls/libc.so.6 
#33 0x00000000004007aa in ?? () 
 
 
Version-Release number of selected component (if applicable): 
kdepim-3.1.3-3.1 
 
How reproducible: 
 
 
Steps to Reproduce: 
1. launch korganizer. 
2. add a few appointments 
3. make active 
4. save calendar (you may or may not get a traceback here) 
5. exit and relaunch korganizer 
   
Actual results: 
traceback (posted above)
Comment 1 Ben Levenson 2004-06-21 15:59:58 EDT
Seems to be working w/ kdepim-3.1.3-3.3.
CLOSING -> CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.