Bug 113456 - Broken pdf output
Broken pdf output
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: xmlto (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-13 23:33 EST by Enrico Scholz
Modified: 2007-04-18 13:01 EDT (History)
0 users

See Also:
Fixed In Version: 1.64.1-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-20 06:45:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2004-01-13 23:33:56 EST
Description of problem:

Generated PDF output is cluttered by measurement tags.
E.g.

-----
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE article PUBLIC "-//OASIS//DTD DocBook XML V4.1.2//EN"
                        
"/usr/share/sgml/docbook/xml-dtd-4.2-1.0-22.1/docbookx.dtd">

<article>
  <section>
    <title>test</title>
    <simpara>test</simpara>
  </section>
</article>
-----

| $ xmlto pdf test.xml

produces an PDF file which contains

"- -4pc - -4pc"

in the upper left corner. Same happens at lists also.
A document which demostrates this is available at
http://www.tu-chemnitz.de/~ensc/fedora.us-build/files/buildsystem.pdf

Version-Release number of selected component (if applicable):

xmlto-0.0.17-1
docbook-style-xsl-1.64.1-2
xmltex-20000118-15
tetex-2.0.2-10


How reproducible:

100%
Comment 1 Tim Waugh 2004-01-14 04:58:30 EST
Fixed in 1.64.1-3.
Comment 2 Enrico Scholz 2004-01-14 15:19:48 EST
Still active on <variablelist>'s. See already told URL for an example
(2nd page).
Comment 3 Tim Waugh 2004-01-15 05:35:10 EST
Please try 1.64.1-4.
Comment 4 Enrico Scholz 2004-01-18 11:10:28 EST
sorry, no change and still in -4


------

<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE article PUBLIC "-//OASIS//DTD DocBook XML V4.1.2//EN"      
                 
"/usr/share/sgml/docbook/xml-dtd-4.2-1.0-22.1/docbookx.dtd">

<article>
  <section>
    <title>test</title>
    <variablelist>
      <varlistentry>
	<term>test</term>
	<listitem>
	  <para>test</para>
	</listitem>
      </varlistentry>
    </variablelist>
  </section>
</article>
Comment 5 Enrico Scholz 2004-01-19 16:43:09 EST
Cool, measurement tags disappeared with -5. But unfortunately, the
text went away with it :(

For an example, just replace the 'test' para above with a long
sentence. The result will be a text in an only 2-3 cm wide column at
the right side
Comment 6 Tim Waugh 2004-01-19 17:01:10 EST
Yes, it all seems to be broken whichever way I look at it. :-(

We might have to back off to an earlier docbook-xsl revision for
XSL-FO output.
Comment 7 Tim Waugh 2004-01-20 06:45:47 EST
Okay, think it's really fixed now.
Comment 8 Enrico Scholz 2004-01-21 20:09:09 EST
Thanks, output is ok now

Note You need to log in before you can comment on or make changes to this bug.