Bug 113489 - ftp doesn't work if userid is over 65534
Summary: ftp doesn't work if userid is over 65534
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: krb5 (Show other bugs)
(Show other bugs)
Version: 2.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL: http://testdrive.hp.com
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-14 16:40 UTC by tim regan
Modified: 2007-11-30 22:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 19:23:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description tim regan 2004-01-14 16:40:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; compaq)

Description of problem:
I manage the HP testDrive program(www.testdrive.hp.com) and we have 
run into a problem when user ids go over 65534 which is related to 
the nfsnobody entry in the password file. Once a user is over the 
65534 number that user can telnet but can't ftp. I have been told 
that this shouldn't be an issue in glibc since the version I am 
running should support large uids. Could you please point me in the 
right direction?

Thanks

Tim

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Get a TestDrive account and log onto a Red Hat system and try to 
do an ftp
2.
3.
    

Additional info:

Comment 1 Ulrich Drepper 2004-09-28 09:49:04 UTC
This has nothing to do with glibc.  glibc since the first Linux
release uses 32 bit uid_t/gid_t.  I'll reassign to the ftp package. 
It might be that you are using the ftp from krb5-workstation.  Please
provide this information.

Comment 2 Thomas Woerner 2004-10-08 11:07:10 UTC
Are you using /usr/bin/ftp or /usr/kerberos/bin/ftp?

Comment 3 tim regan 2004-10-18 18:33:08 UTC
We are using /usr/kerberos/bin/ftp.

Tim

Comment 4 Thomas Woerner 2004-10-19 08:20:11 UTC
Then this is a krb5 bug, reassigning.

Comment 6 RHEL Product and Program Management 2007-10-19 19:23:18 UTC
This bug is filed against RHEL2.1, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products.  Since
this bug does not meet that criteria, it is now being closed.

For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/

If you feel this bug is indeed mission critical, please contact your
support representative.  You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.