Bug 113495 - Domain users fail to authenticate
Domain users fail to authenticate
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-14 12:55 EST by Kenneth Porter
Modified: 2014-08-31 19:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-30 12:37:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Diff between Fedora 3.0.0 and Samba 3.0.1 spec files (7.35 KB, patch)
2004-01-14 13:57 EST, Kenneth Porter
no flags Details | Diff

  None (edit)
Description Kenneth Porter 2004-01-14 12:55:43 EST
Copied reply from Samba mailing list. Resolution appears to be to
update Fedora package to 3.0.1 from upstream source.

Date: Sat, 10 Jan 2004 00:25:41 +0000 (GMT)
From: John H Terpstra <jht@samba.org>
To: ken@sewingwitch.com
Cc: samba@lists.samba.org
Subject: Re: [Samba] Domain group not working in valid users

On Sat, 10 Jan 2004, Kenneth Porter wrote:

> Using samba-3.0.0-15 on Fedora Core 1.
>
> I have a group "Electronics Testing" on my Win2k AD server and added
this
> to a share in my smb.conf:
>
> valid users = @"electronics testing"
>
> A user in this group is unable to connect. A local user added to valid
> users is able to connect, so other share settings look ok. I see this in
> the log:
>
> [2004/01/09 13:38:00, 10] lib/username.c:user_in_list(508)
>   user_in_list: checking user |samba| against |@electronics testing|
> [2004/01/09 13:38:00, 5] lib/username.c:user_in_netgroup_list(307)
>   Unable to get default yp domain
>
> The group exists and I can see it with "wbinfo -g", and I can see
the group
> listed in the test user's group list.
>
> Any idea what's going wrong?

Yes. This was fixed in 3.0.1.

>
> I want to allow the Win2k admin to control who has access to this
share, so
> I don't have to create local accounts for all the people who need
access.
>
>

- John T.
-- 
John H Terpstra
Email: jht@samba.org
Comment 1 Kenneth Porter 2004-01-14 13:21:35 EST
Note that Samba provides RPM's (binary and source) for Fedora here:

http://us2.samba.org/samba/ftp/Binary_Packages/Fedora/
Comment 2 Kenneth Porter 2004-01-14 13:57:37 EST
Created attachment 96985 [details]
Diff between Fedora 3.0.0 and Samba 3.0.1 spec files

I've attached a diff of the Fedora and Samba spec files for reference. I expect
there will be some merging of these for the next Fedora package release.
Comment 3 Kenneth Porter 2004-01-21 15:24:07 EST
Looks like 3.0.2-1rc1 is in the development directory. Here's a mirror:

ftp://linux.stanford.edu/pub/mirrors/fedora/linux/core/development/SRPMS/samba-3.0.2-1rc1.src.rpm

Note You need to log in before you can comment on or make changes to this bug.