Bug 1135042 - lightning info page not linked into "dir"
Summary: lightning info page not linked into "dir"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lightning
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jochen Schmitt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-28 17:37 UTC by Tom Tromey
Modified: 2014-09-10 13:27 UTC (History)
4 users (show)

Fixed In Version: lightning-2.0.4-2.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-10 13:27:18 UTC


Attachments (Terms of Use)

Description Tom Tromey 2014-08-28 17:37:18 UTC
I installed lightning-devel, which includes an "info" manual.
I expected the info manual to be linked into the top-level info "dir"
file.  However, it is not.

You can reproduce with:

$ yum install lightning-devel
$ info

Then when info starts, try "m lightning".
This fails since there is no menu entry.

I didn't look into the sources but this problem usually has one
of two causes:

1. The info file is missing "dir entries".
2. The RPM forgets to invoke install-info

Comment 1 Fedora Update System 2014-08-29 19:32:56 UTC
lightning-2.0.4-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/lightning-2.0.4-2.fc20

Comment 2 lnie 2014-09-01 02:24:31 UTC
lightning-2.0.4-2.fc20 works

Comment 3 Fedora Update System 2014-09-02 06:47:01 UTC
Package lightning-2.0.4-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lightning-2.0.4-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-10094/lightning-2.0.4-2.fc20
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2014-09-10 13:27:18 UTC
lightning-2.0.4-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.