Bug 1135079 - Rubygem-Staypuft: puppet-nova calls nova-manage with --vlan when it means --vlan_start
Summary: Rubygem-Staypuft: puppet-nova calls nova-manage with --vlan when it means --...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: 5.0 (RHEL 7)
Assignee: Mike Burns
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks: 1126072
TreeView+ depends on / blocked
 
Reported: 2014-08-28 19:22 UTC by Alexander Chuzhoy
Modified: 2014-09-08 05:44 UTC (History)
3 users (show)

Fixed In Version: openstack-puppet-modules-2014.1-21.7.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-02 18:11:01 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1125 normal SHIPPED_LIVE openstack-packstack and openstack-puppet-modules bug fix advisory 2014-09-02 22:09:22 UTC

Description Alexander Chuzhoy 2014-08-28 19:22:17 UTC
Rubygem-Staypuft:  puppet-nova calls nova-manage with --vlan when it means --vlan_start 


In lib/puppet/provider/nova_network/nova_manage.rb, puppet-nova is using --vlan when it means --vlan_start. This results in a command line such as:

  nova-manage network create novanetwork 192.168.32.0/21 6 --vlan 10

And this will fail, because it will attempt to create multiple networks with vlan id 10.


As a result deploying Nova with Vlan network type fails. The following message is in the report:
change from absent to present failed: Execution of '/usr/bin/nova-manage network create novanetwork 192.168.32.0/21 6 --vlan 10' returned 1: Command failed, please check log for more info


This bus is reported upstream (https://bugs.launchpad.net/puppet-nova/+bug/1362772) and it seems like the patch proposed there resolves the issue.

Comment 1 Alexander Chuzhoy 2014-08-28 19:23:18 UTC
Environment:
rhel-osp-installer-0.1.10-2.el6ost.noarch
openstack-foreman-installer-2.0.22-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-puppet-modules-2014.1-21.4.el6ost.noarch

Comment 3 Alexander Chuzhoy 2014-08-29 20:02:11 UTC
Verified: 
rhel-osp-installer-0.1.10-2.el6ost.noarch
openstack-foreman-installer-2.0.22-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-puppet-modules-2014.1-21.7.el6ost.noarch


The issue didn't reproduce, the deployment has completed successfully.

Comment 5 errata-xmlrpc 2014-09-02 18:11:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1125.html


Note You need to log in before you can comment on or make changes to this bug.