Bug 1135623 - Update instructions fail to mention how old metric data can be purged after migration/upgrade
Summary: Update instructions fail to mention how old metric data can be purged after m...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Documentation
Version: JON 3.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: GA
: JON 3.3.0
Assignee: Jared MORGAN
QA Contact: Mike Foley
Jared MORGAN
URL:
Whiteboard:
Keywords: Documentation
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-29 19:51 UTC by Larry O'Leary
Modified: 2018-12-05 19:02 UTC (History)
3 users (show)

(edit)
The installation and upgrade instructions for upgrading from JBoss ON <3.2 to JBoss ON >=3.2 did not provide information on how to remove the legacy metric data from the relational database. If users did not perform this step, legacy data persisted in the system, and continued to use many GB of database space. In some instances, database performance was impacted. Multiple changes were made to the Installation Guide to fix this issue. The "About the Upgrade Script" section now has two extra database management parameters described in the "Options for Upgrading" subsection. The "Upgrading the JON Server and Components" procedure has a specific call-out in Step 8 that prompts users to check the "Options for Upgrading" section so they are aware of the new parameters. This content is available for review at access.redhat.com/documentation/en-US/Red_Hat_JBoss_Operations_Network/3.3/html-single/Installation_Guide/index.html#upgrade-script
Clone Of:
(edit)
[Install Guide]
Last Closed: 2014-12-11 14:02:44 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1098572 None None None Never

Internal Trackers: 1098572

Description Larry O'Leary 2014-08-29 19:51:15 UTC
Description of problem:
The installation and upgrade instructions for upgrading[1] from JBoss ON <3.2 to JBoss ON >=3.2 does not provide information on how to remove the legacy metric data from the relational database.

By default, when the data migration is run as part of the upgrade, metric data is left in the database. It appears that the expectation is that the user should either provide the --delete-data command-line argument to the upgrade command to trigger the deletion of the data on successful migration of the data or manually run the data migration tool and pass the --delete-only command-line argument.

[1]: https://access.redhat.com/documentation/en-US/Red_Hat_JBoss_Operations_Network/3.2/html/Installation_Guide/managing-servers.html#upgrading

Version-Release number of selected component (if applicable):
Revision 3.2-13

Additional info:
It is not clear what options should be provide and how this is actually supposed to be used. But the problem is clear. User's that do not perform this step will have their legacy data forever stored with absolutely no value and cleanup and it will continue to use many GB of database space. In some instances, this will continue to hurt database performance even though the data isn't actually getting used.

Additionally, it is important to note that this only applies to upgrading from 3.1.x and earlier. I am not sure what purpose -- if any -- the data migration utilities provide during upgrades from 3.2 to later versions.

Comment 1 Jared MORGAN 2014-10-02 23:27:56 UTC
==Legacy Metric Data==

Applicable for upgrading from releases prior to 3.2 (I read this as 3.1.x) to releases later than 3.2 (I read this as 3.2.x and greater).

Need to specify that when data migration is run as part of an upgrade, that the user must specify the --delete-data command with the upgrade command. 

A user can manually run the migration tool and specify the --delete-only argument to remove the metric data.


Note You need to log in before you can comment on or make changes to this bug.