Bug 113574 - Sorting folder list by title does not change sort order
Summary: Sorting folder list by title does not change sort order
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise CMS
Classification: Retired
Component: APLAWS-usability   
(Show other bugs)
Version: nightly
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tzu-Mainn Chen
QA Contact: Daniel Berrange
URL: http://aplaws-ws3.ccm-demo.redhat.de/...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-15 15:14 UTC by Lindsay Ould
Modified: 2010-09-03 14:27 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-03 14:27:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lindsay Ould 2004-01-15 15:14:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET 
CLR 1.1.4322)

Description of problem:
Select title header from folder list to sort by title does not 
produce an alphabetical list of items

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.http://aplaws-ws3.ccm-demo.redhat.de/ccm/content/admin/index.jsp
2.select title header to folder list  
3.
    

Actual Results:  folder list does not change

Expected Results:  Expect sort order to change to alphabetical or 
reverse alphabetical list

Additional info:

Comment 1 Scott Seago 2004-01-15 16:54:51 UTC
Actually, it looks like it is sorting, but it's doing a case-sensitive
sort (i.e. capital letters first). This needs to be made case-insensitive.

Comment 2 Scott Seago 2004-01-15 17:05:00 UTC
Additional comment from Dan on this:
<danpb> but we should beware of performance if we do that
<danpb> we might need to define a functional index on lower(title) 

We'll need to deal with pg and oracle issues here.


Comment 3 Randy Graebner 2004-01-15 21:43:57 UTC
I have added the "lower" filters on the sorting but I have not done
anything in terms of checking for performance.

Comment 4 Scott Seago 2004-01-17 20:51:31 UTC
This is now fixed on the staging server, checked into the aplaws-w3
branch, to be integrated on dev next week.

Comment 5 David Lawrence 2006-07-18 03:43:55 UTC
QA_READY has been deprecated in favor of ON_QA. Please use ON_QA in the future.
Moving to ON_QA.


Note You need to log in before you can comment on or make changes to this bug.