Bug 1135782 - libreport not thread safe?
Summary: libreport not thread safe?
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreport
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Filak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1133055 1133710 1135767 1138899 (view as bug list)
Depends On:
Blocks: 1134407
TreeView+ depends on / blocked
 
Reported: 2014-08-31 13:55 UTC by Mikhail
Modified: 2016-12-01 00:47 UTC (History)
9 users (show)

Fixed In Version: libreport-2.2.3-6.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-23 04:35:13 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1153479 None None None Never

Internal Links: 1153479

Description Mikhail 2014-08-31 13:55:56 UTC
Description of problem:
libreport not thread safe?

When I try run report wizard for several problems simultaneously I saw in windows header name of previously running report process.

Demonstration: https://drive.google.com/file/d/0B0nwzlfiB4aQSjVJVVVLY05kZDQ/edit?usp=sharing

Comment 1 Jakub Filak 2014-09-09 05:16:49 UTC
Thank you for taking the time to report this bug. libreport doesn't use threads at all. Unfortunately, I'm not able to reproduce the misbehaviour you are experiencing.

What's your version of gnome-abrt?

Comment 2 Jakub Filak 2014-09-09 10:31:39 UTC
Upstream commit https://github.com/abrt/libreport/commit/e457344b79f872294338b7ec3006709a2d9f806a fixes this bug.

Comment 3 Jakub Filak 2014-09-09 10:32:38 UTC
*** Bug 1135767 has been marked as a duplicate of this bug. ***

Comment 4 Jakub Filak 2014-09-09 10:33:47 UTC
*** Bug 1133055 has been marked as a duplicate of this bug. ***

Comment 5 Jakub Filak 2014-09-09 10:37:20 UTC
*** Bug 1133710 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2014-09-09 13:43:21 UTC
libreport-2.2.3-6.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/libreport-2.2.3-6.fc21

Comment 7 Fedora Update System 2014-09-10 02:14:39 UTC
Package libreport-2.2.3-6.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreport-2.2.3-6.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-10543/libreport-2.2.3-6.fc21
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2014-09-23 04:35:13 UTC
libreport-2.2.3-6.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Jakub Filak 2014-10-14 13:09:55 UTC
*** Bug 1138899 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.