Bug 113596 - Buildroot traces in /usr/bin/* and one perl module
Summary: Buildroot traces in /usr/bin/* and one perl module
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: spamassassin   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 97747
TreeView+ depends on / blocked
 
Reported: 2004-01-15 17:45 UTC by Ville Skyttä
Modified: 2007-04-18 17:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-20 04:53:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix buildroot traces, enable openssl, allow stripping spamc (979 bytes, patch)
2004-01-15 17:46 UTC, Ville Skyttä
no flags Details | Diff
Fix buildroot traces, enable openssl, allow stripping spamc, honor optflags (1012 bytes, patch)
2004-01-19 20:29 UTC, Ville Skyttä
no flags Details | Diff

Description Ville Skyttä 2004-01-15 17:45:12 UTC
Some perl scripts from spamassassin-2.61-2, /usr/bin, as well as one
module contain buildroot traces.

The fix: use DESTDIR=$RPM_BUILD_ROOT instead of PREFIX in "perl
Makefile.PL".

While at it, I'd suggest SSL-enabling spamc as well as making it
possible for older rpm versions to strip it.

Will attach a patch which does the above.

Comment 1 Ville Skyttä 2004-01-15 17:46:15 UTC
Created attachment 97034 [details]
Fix buildroot traces, enable openssl, allow stripping spamc

Comment 2 Ville Skyttä 2004-01-15 17:47:49 UTC
By the way, this partially "fixes" #97747.

Comment 3 Miloslav Trmac 2004-01-15 23:01:35 UTC
Overlaps with bug 90202, but not strictly a duplicate.

Comment 4 Ville Skyttä 2004-01-19 20:29:11 UTC
Created attachment 97105 [details]
Fix buildroot traces, enable openssl, allow stripping spamc, honor optflags

AFAICS here are the most important parts to be applied to spamassassin 2.62-2. 
Further cleanups maybe sometime later.

Changed since my previous patch:
- Trailing slash to DESTDIR (bug 90202 comment 14).
- export optflags so they're honored, affects spamc only.

Comment 5 Warren Togami 2004-01-20 04:53:21 UTC
2.62-3 applied to rawhide
Please re-open if you have more cleanups.


Note You need to log in before you can comment on or make changes to this bug.