Bug 113621 - LTC5796-up2date fails to collect hardware information
LTC5796-up2date fails to collect hardware information
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-15 17:00 EST by IBM Bug Proxy
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 21:43:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2004-01-15 17:00:46 EST
The following has be reported by IBM LTC:  
up2date fails to collect hardware information
Hardware Environment:
  plinuxt01.tw.ibm.com
  P615+ 7029-6E3
  Network-Mainboard:
    1port x 1 (10/100M)  
    1port x 1 (Gigabit)
  Network-External:
    1port x 1 (5700 Gigabit Ethernet-SX), on slot 1
    2port x 1 (5706 2-port Base-TX Gigabit Ethernet PCI-X Adapt) on slot 4
  CPU:		
    1-way 1.2 GHz Power4+ Processor
  MEM:
    8G

Software Environment:
  RedHat Enterprise Linux 3 for ppc64 GM, Update 1 beta (respin re0108)

Steps to Reproduce:
1.Install the new rhel 3 Update 1 respin(re0108)
2.Execute "up2date --register&"
3.Go through the wizard until Step 3. "Register a System Profile -
Hardware"
4.Check the information collected about "Linux version", Hostname, IP
address

Actual Results:
  The hardware information shown as "ERROR"

Expected Results:
  Correct hardware information shown on GUI.

Additional Information:
  On the terminal, the following error is shown:

[root@plinuxt01 root]# up2date --register
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 752, in 
onProfilePagePrepare    self.hardware = hardware.Hardware()
  File "/usr/share/rhn/up2date_client/hardware.py", line 510, in Hardware
    ret = read_network()
  File "/usr/share/rhn/up2date_client/hardware.py", line 338, in
read_network
    hostname, ipaddr = findHostByRoute()
  File "/usr/share/rhn/up2date_client/hardware.py", line 316, in 
findHostByRoute    s.connect((server, 80))
socket.error: (110, 'Connection timed out')Created an attachment (id=2288)
The screen dump of the problem
  If we remove the "plinuxt01.tw.ibm.com" and "plinuxt01" from
/etc/hosts, 
the hardware information will be shown correctly.

Ex. Original /etc/hosts:
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1       plinuxt01.tw.ibm.com    plinuxt01 
localhost.localdomain   
localhost

Remove the "plinuxt01.tw.ibm.com" and "plinuxt01" from /etc/hosts,

# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1    localhost.localdomain   localhost

then "up2date --register" will collect the hardware information OK.

The question is how the hostname(s) got into the loopback IP address
line in 
the first place? It surely messed up the box 's network connections. 
During the installation, if "DHCP" is selected and hostname is specified,
then installer will produce "/etc/hosts" that contains both the
hostname and 
localhost in a single line. That's how hostname got into the loopback IP 
address line. (And it seems reasonable since the box is using DHCP.)

  Later when using "up2date --register", the Python code to detect
hardware
(/usr/share/rhn/up2date_client/hardware.py) will fail at
"findHostByRoute".

  
  Look like up2date pickup the IP address from the /etc/hosts file
before getting 
from the DNS. I'm not sure there is any change in up2date lately and
why the 
hostname is inserted in the loopback line. We need to open this bug on
rehat 
bugzilla.
Glen/Greg,
Please report this bug to RedHat.
Thanks.
Comment 1 IBM Bug Proxy 2004-02-06 09:54:40 EST
----- Additional Comments From khoa@us.ibm.com  2004-02-06 09:52 -------
I've put this on RHEL3 QU3 list as a Sev 2. 
Comment 2 Bob Johnson 2004-08-10 14:37:11 EDT
new up2date as of 8/2/04, please retest.
Comment 3 IBM Bug Proxy 2004-08-11 04:29:43 EDT
----- Additional Comments From wangzyu@cn.ibm.com  2004-08-11 04:30 -------
the bug has been fixed.
    Firstly, I retest it based on kernel 2.4.21-17.EL. "up2date --register" 
collect the hardware information currently.the version of up2date is 4.2.29.
    Secondly, I got the new up2date(4.2.33-1) from rhn. "up2date --register" 
collect the hardware information currently too.
whether the file /etc/hosts has "plinuxt20.ppc.cn.ibm.com", the hardware 
information always correct. 

Note You need to log in before you can comment on or make changes to this bug.