Bug 113622 - when trying to Kickstart an AS2.1 image on a RH9 server the installer stops wilt a "unhandled exception" please send file to bugzilla
when trying to Kickstart an AS2.1 image on a RH9 server the installer stops w...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-15 17:03 EST by Mark Edlin
Modified: 2007-04-18 13:01 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-19 17:36:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Out put from unhandled exception error during kickstart (58.95 KB, text/plain)
2004-01-15 17:05 EST, Mark Edlin
no flags Details

  None (edit)
Description Mark Edlin 2004-01-15 17:03:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007

Description of problem:
When trying to kickstart an AS2.1 image, loaded on a RH9 server, I get
the following message. 

An unhandled exception has occured. This is most likely a bug. Please
copy the text of this exception to a floppy, then file a detailed bug
report against anaconda.

Traceback (innermost last):
  File "/usr/bin/anaconda", line 668, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/text.py", line 364, in run
    (step, args) = dispatch.currentStep()
  File "/usr/lib/anaconda/dispatch.py", line 243, in currentStep
    self.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 143, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 208, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 116, in readPackages
    id.comps = method.readComps(id.hdList)
  File "/usr/lib/anaconda/image.py", line 17, in readComps
    return ComponentSet(self.tree + '/RedHat/base/comps', hdlist)
  File "/usr/lib/anaconda/comps.py", line 797, in __init__
    self.readCompsFile(file, self.packages)
  File "/usr/lib/anaconda/comps.py", line 550, in readCompsFile
    list = self.expressions.get(packages[l])
  File "/usr/lib/anaconda/comps.py", line 153, in __getitem__
    return self.packages[item]
KeyError: XFree86-KOI8-R


Version-Release number of selected component (if applicable):
RH9 kernel-smp-2.4.20-28.9 -

How reproducible:
Always

Steps to Reproduce:
1.boot from AS2.1 cd on server to kickstart
2.at prompt "linux ks=floppy"
3.
    

Actual Results:  Traceback (innermost last):
  File "/usr/bin/anaconda", line 668, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/text.py", line 364, in run
    (step, args) = dispatch.currentStep()
  File "/usr/lib/anaconda/dispatch.py", line 243, in currentStep
    self.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 143, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 208, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 116, in readPackages
    id.comps = method.readComps(id.hdList)
  File "/usr/lib/anaconda/image.py", line 17, in readComps
    return ComponentSet(self.tree + '/RedHat/base/comps', hdlist)
  File "/usr/lib/anaconda/comps.py", line 797, in __init__
    self.readCompsFile(file, self.packages)
  File "/usr/lib/anaconda/comps.py", line 550, in readCompsFile
    list = self.expressions.get(packages[l])
  File "/usr/lib/anaconda/comps.py", line 153, in __getitem__
    return self.packages[item]
KeyError: XFree86-KOI8-R

Expected Results:  Start the installation of AS2.1

Additional info:
Comment 1 Mark Edlin 2004-01-15 17:05:32 EST
Created attachment 97043 [details]
Out put from unhandled exception error during kickstart
Comment 2 Jeremy Katz 2004-01-16 13:54:16 EST
Where did you get your 2.1 tree?  It looks like the header list
doesn't reference all of the packages.
Comment 3 Mark Edlin 2004-01-16 14:56:47 EST
I preformed a " cp -var" of the CD's I made from the ISO's off the 
web site. I copied them into the /var/ftp/pub/RedHat/AS2.1 of the RH9 
server. Then I ran "anaconda-runtime" to update the RPM list.

If this is incorect please let me know. Also, I did a test install 
from the CD's, made from the ISO images, and it worked fine. So 
ibelive the CD's to be good.

Thanks,

Mark Edlin
Comment 4 Mark Edlin 2004-01-19 17:36:26 EST
I recopied the ISO's and choose to overwrite the TRANS.TBL files and 
that seem to fix my errors.

Note You need to log in before you can comment on or make changes to this bug.