Bug 113660 - AGP cards are slow in XFree86 4.3
AGP cards are slow in XFree86 4.3
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On: 114125
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-16 01:10 EST by William M. Quarles
Modified: 2007-04-18 13:01 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-16 01:48:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William M. Quarles 2004-01-16 01:10:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031016

Description of problem:
I saw a message on the GATOS project mailing list saying that there is
a major bug in XFree86 4.3: AGP cards are running slower than PCI
cards.  The best test of this is a 3D game.  I tried the Linux game
Chromium out, and sure enough the game wouldn't work properly; it
behaved as though the system did not have 3D acceleration.  I decided
to install Red Hat Linux 8.0 on a different hard drive in my computer
and see if the acceleration was restored by using XFree86 4.2.1, and
in fact the speed was restored.

If this was a known issue when Red Hat Linux 9 was released, I don't
think XFree86 4.3 should have been part of the release.

Version-Release number of selected component (if applicable):
XFree86-4.3.0-2.90.43

How reproducible:
Always

Steps to Reproduce:
1.Install Red Hat Linux 8.0 with Chromium on a system with an AGP card
with DRI support
2.Play Chromium
3.Upgrade to Red Hat Linux 9, or use a similar computer running Red
Hat Linux 9.0
4. Play Chromium

Actual Results:  Chromium works on Red Hat Linux 8.0, but not on Red
Hat Linux 9.

Expected Results:  Chromium should run smoothly on both computers.

Additional info:

My computer has the following:
Dell Dimension XPS T-series with Intel 440BX chipset
Pentium III 1.1 GHz
256 MB ECC SDRAM
ATI All-In-Wonder Radeon AGP video card (running at 2x)
Comment 1 William M. Quarles 2004-01-16 01:48:29 EST
I screwed up, this is fixed in XFree86 as Red Hat distributes it, the
problem is likely in the GATOS XFree86 software for Radeons.
Comment 2 Mike A. Harris 2004-01-16 09:29:10 EST
Exactly.
Comment 3 Mike A. Harris 2004-01-16 09:30:15 EST
more specifically, I should say....  Don't file bug reports to
Red Hat, if you are using _any_ 3rd party video drivers or kernel
modules, be they open source or proprietary.  ANything we do not
ship is explicitly unsupported by us, and only supported by the
people who provided it to you, or the community.
Comment 4 William M. Quarles 2004-01-22 20:51:20 EST
I thought I tried the Red Hat drivers also, I must have made a
mistake.    I'm sorry for the trouble.

In any case, I troubleshot the heck out of that problem and opened a
wide discussion on the list, which is now Bug 114125.  And yes, it is
a 3rd party driver, but a Red Hat update broke the compatibility.
Then again, your probably already got that e-mail.

Note You need to log in before you can comment on or make changes to this bug.