This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 113662 - old broken K&R code duplicated ?
old broken K&R code duplicated ?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Canna (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Bill Huang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-16 04:49 EST by d.binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 3.7p1-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-18 20:50:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2004-01-16 04:49:02 EST
Description of problem:

I've just been having a look at package Canna-3.6-24 from Fedora.
I found

[root@localhost SPECS]# grep searchdesc
../BUILD/Canna-3.6/Canna36p4/dic/ideo/pubdic/pod.c
searchdesc(hin, tan, yom)
    dp = searchdesc(dhinshi);

This means that routine searchdesc is defined with three parameters,
but only gets called with one. This is a problem for any
use of parameters tan & yom in the searchdesc routine.

Suggest remove parameters tan & yom. The source code is

static struct descpack *
searchdesc (hin, tan, yom)
     Wchar *hin, **tan, **yom;
{

Suggest also use ISO function prototypes. K&R code has been deprecated
for about fifteen years now.

static struct descpack *
searchdesc ( Wchar * hin)
{

This source code, and so this problem, seems to be duplicated from
package FreeWnn.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Akira TAGOH 2004-01-18 20:50:25 EST
Fixed in 3.7p1-2.

Note You need to log in before you can comment on or make changes to this bug.