Bug 11369 - A non-compatible arch rpm results in a misleading message
A non-compatible arch rpm results in a misleading message
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
8.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-11 13:47 EDT by Mark Hatle
Modified: 2007-04-18 12:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-07 15:01:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Hatle 2000-05-11 13:47:42 EDT
If you try to install a PPC.rpm on an intel machine you (usually) get the
following message:

error: failed dependencies:
	ld.so.1 is needed by zsh-3.0.5-15

when the correct error should be:

package %s-%s-%s is for a different architecture


The misleading error message seems to be because the dependencies are
checked first, and then the arch, os, etc are checked next.  It would be
very helpful to check the arch/os first and then the dependencies.
Comment 1 Jeff Johnson 2000-08-07 09:38:39 EDT
This problem will be addressed after rpm-4.0 is released.
Comment 2 Alan Cox 2002-12-14 18:23:03 EST
Confirmed bug still present in 8.0
Comment 3 Paul Nasrat 2005-06-07 15:01:36 EDT
rpm -q rpm; uname -m
rpm-4.4.1-22.i386
i686

rpm -ivh yaboot-1.3.12-9.ppc.rpm
Preparing...                ########################################### [100%]
        package yaboot-1.3.12-9 is intended for a ppc architecture

Note You need to log in before you can comment on or make changes to this bug.