Bug 113691 - weather applet looses connectivity after system moved to a different network (DHCP in both locations)
weather applet looses connectivity after system moved to a different network ...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-vfs2 (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-16 11:06 EST by Norbert Roma
Modified: 2013-04-02 00:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-04 04:36:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Norbert Roma 2004-01-16 11:06:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
The weather applet in the panel looses connection to the weather
server after the system (laptop) is moved from one private netowrk,
say 192.168.2.0/24, (bhind a NAT firewall) to another private subnet,
say 10.100.0.0/24 (behind another firewall).  All other components
retain full network connectivity on both networks.  The applet works
on both networks when located on the network that it was connected to
when first started (ie, it will work when first started in either
location, and it will resume working when brought back to the original
location after having been elsewhere).


Version-Release number of selected component (if applicable):
weather report 2.4.1 (gnome-applets-2.4.1-1)

How reproducible:
Always

Steps to Reproduce:
1.Log in and make sure you have the applet in the panel.
2.Disconnect from your network
3. Connect to a different network and try to update the weather report
    

Actual Results:  Reports "Retrieval failed" in step 3 above

Expected Results:  Should report weather conditions

Additional info:
Comment 1 Mark McLoughlin 2004-07-19 09:48:46 EDT
Do you still see this problem with Fedora Core 2?
Comment 2 Alex Lancaster 2004-07-29 07:31:27 EDT
I still get this problem in Fedora Core 2 (with updates).  It seems to
be related to this upstream bug, which has been open since March 2002!

http://bugzilla.gnome.org/show_bug.cgi?id=76283
Comment 3 Mark McLoughlin 2004-08-04 04:33:16 EDT
Okay, seems to be a gnome-vfs bug - moving there, but closing as
resolved UPSTREAM.
Comment 4 Mark McLoughlin 2004-08-04 04:35:37 EDT
The fix is in gnome-vfs 2.7.90 and, as such, will appear soon in FC3.

Note You need to log in before you can comment on or make changes to this bug.