Bug 113724 - 6.4 All date fields to be augmented with a radio box labelled today
6.4 All date fields to be augmented with a radio box labelled today
Status: CLOSED WONTFIX
Product: Red Hat Enterprise CMS
Classification: Retired
Component: APLAWS-usability (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: Scott Seago
Daniel Berrange
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-16 15:04 EST by Lindsay Ould
Modified: 2008-10-06 09:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-06 09:25:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lindsay Ould 2004-01-16 15:04:52 EST
Description of problem:
Please clarify the reason behind this.  I believe the ideal solution 
would be to default all date boxes to today's date  - the additional 
radio box is confusing.
If this is the only solution at present, currently the box is not 
checked by default and the date is not displaying in the date field


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.create an event
2.View date fields
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Daniel Berrange 2004-01-16 15:16:49 EST
Pre-filling all the text boxes with the current date would complicate
matters for date fields which are typically optional, since the user
now has to manually remove all the pre-filled data. 
Comment 2 Vadim Nasardinov 2004-01-16 15:22:28 EST
What if we make it easier for the user to select the current day
(if they so desire) by populating the drop-down list 
in the following order:

 today (16th)
 1
 2
 ..
 15
 16
 17
 ..
 31

Comment 3 Randy Graebner 2004-01-16 15:37:00 EST
Current the "day" field is a text field, not a drop down so that is
not possible with the current widget and would require converting to a
text box (probably with javascript to change depending on the selected
month).

The check box defaults to true for most dates.  However, it defaults
to unchecked for things like "launch date" where the user would rarely
want to use "today".  It also is "unchecked" if the date already has a
value so that the current value is not overridden.  However, in most
cases if the item does not have a current value it should default to
being checked.
Comment 4 Lindsay Ould 2004-01-16 15:41:42 EST
It just looks very messy with the day field blank and a 'today' box 
next to the field - Can I ask you to suggest a solution the best 
option considering present timescales 
Comment 5 Scott Seago 2004-01-16 16:30:16 EST
In addition, the requirements as stated (at least as I received them)
included the 'today' toggle. For this week, there's nothing new we can
do. As for changes before final release, to make any change would
require a change which doesn't impact current functionality. For
optional fields, automatically filling in today's date would cause
fields which ought to remain blank to be accidentally filled in.
Comment 6 Lindsay Ould 2004-01-29 12:11:40 EST
I have had a detailed look at this again today.  
My recommendations are:
'today' toggle does not check today's date as it stands so is not 
working correctly.
At present, the current date widget is inconsistent.  Controlled 
lists for month and year are present but day is just a text box.  
This really needs to be improved so that the way each field works is 
consistent.  There is no problem about the day list containing 1-31 
and a user resolving how many days in the month.  By default all 
lists could contain a blank so that the user chooses month day and 
year or leaves blank if required.  The today toggle would not 
necessarily be needed unless if you checked it, it would 
automatically fill the boxes with todays date.  In some cases today's 
date is filled automatically e.g. lifecycle start date - I assume you 
could still do this.
Please let me know how we can resolve this 
Comment 7 Daniel Berrange 2004-02-17 06:05:13 EST
As discussed during our meeting last week, we will remove the 'today'
checkbox altogether since it just doesn't work well in practice. The
longer term solution will be to incorporate a JavaScript popup date
picker. We'll evaluate how much work this will involve to determine
when we'll be able to integrate such functionality.
Comment 8 Scott Seago 2004-02-17 10:03:53 EST
Dan, does this mean we should simply revert Randy's changes entirely,
going back to prior behavior?
Comment 9 Daniel Berrange 2004-02-17 10:06:37 EST
Remove the 'today' checkbox altogether, putting Date field back to
what it originally was prior to WS3
Comment 10 Scott Seago 2004-02-17 12:56:23 EST
Removed @40477.
Comment 11 James Kearns 2004-02-22 15:02:14 EST
I'm still seeing the today checkbox.
Comment 12 David Lawrence 2006-07-17 23:12:11 EDT
QA_READY has been deprecated in favor of ON_QA. Please use ON_QA in the future.
Moving to ON_QA.

Note You need to log in before you can comment on or make changes to this bug.