Bug 113748 - problem doing ccm load with oracle on tip
problem doing ccm load with oracle on tip
Status: CLOSED NOTABUG
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
medium Severity high
: ---
: ---
Assigned To: Vadim Nasardinov
Jon Orris
:
Depends On:
Blocks: 106481
  Show dependency treegraph
 
Reported: 2004-01-16 20:20 EST by Bryan Che
Modified: 2007-04-18 13:01 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-19 12:51:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Che 2004-01-16 20:20:16 EST
At changelist 39472 and running with oracle.  I did a 

ccm load --data --schema --config --parameter-file devel.properties
ccm-core ccm-cms ccm-cms-types-article ccm-cms-types-mparticle

and got an error.  I was able to load with postgres at the tip with no
problems.

**********

2004-01-16 20:05:46,606 [ main] INFO  runtime.Startup - Running Legacy
Init for class com.arsdigita.cms.Initializer (2 out of 4)
2004-01-16 20:05:46,796 [ main] INFO  initializer.Script - Running
initializer com.arsdigita.cms.installer.Initializer (1 of 8)
2004-01-16 20:05:47,258 [ main] ERROR kernel.SiteNode -
getRootSiteNode:: Root site node not found.
2004-01-16 20:05:47,384 [ main] ERROR kernel.SiteNode -
getRootSiteNode:: Root site node not found.
2004-01-16 20:05:47,453 [ main] INFO  initializer.Script - Running
initializer com.arsdigita.cms.installer.xml.ContentTypeInitializer (2
of 8)
2004-01-16 20:05:47,796 [ main] INFO  initializer.Script - Running
initializer com.arsdigita.cms.publishToFile.Initializer (3 of 8)
2004-01-16 20:05:47,802 [queue] INFO  publishToFile.QueueManager -
Start polling queue in 30s.
2004-01-16 20:05:47,815 [ main] INFO  initializer.Script - Running
initializer com.arsdigita.cms.installer.SectionInitializer (4 of 8)
2004-01-16 20:05:48,593 [ main] ERROR kernel.SiteNode -
getRootSiteNode:: Root site node not found.
2004-01-16 20:05:58,751 [ main] ERROR kernel.SiteNode -
getRootSiteNode:: Root site node not found.
Exception in thread "main" java.lang.NullPointerException
        at
com.arsdigita.cms.installer.SectionInitializer.retrieveContentSection(SectionInitializer.java:166)
        at
com.arsdigita.cms.installer.SectionInitializer.doStartup(SectionInitializer.java:150)
        at
com.arsdigita.kernel.BaseInitializer$1.excurse(BaseInitializer.java:53)
        at
com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
        at
com.arsdigita.kernel.BaseInitializer.startup(BaseInitializer.java:56)
        at com.arsdigita.initializer.Script.startup(Script.java:197)
        at com.arsdigita.initializer.Script.startup(Script.java:168)
        at
com.arsdigita.runtime.LegacyInitializer.init(LegacyInitializer.java:120)
        at
com.arsdigita.runtime.CompoundInitializer.init(CompoundInitializer.java:139)
        at
com.arsdigita.runtime.CompoundInitializer.init(CompoundInitializer.java:139)
        at com.arsdigita.runtime.Startup.run(Startup.java:218)
        at com.arsdigita.runtime.Startup.run(Startup.java:243)
        at com.arsdigita.packaging.Load.run(Load.java:349)
        at com.arsdigita.packaging.MasterTool.main(MasterTool.java:89)
Comment 1 Richard Li 2004-01-17 07:17:02 EST
vadim: is this your recent changes?
Comment 2 Vadim Nasardinov 2004-01-17 10:41:48 EST
Yes.
Comment 3 Vadim Nasardinov 2004-01-19 11:07:08 EST
Bryan,

I can't reproduce this.  I remember seeing the above stack
trace at some point before change 39457, but I think I fixed it.

Can you p4 sync, "ant clean deploy", and retest?  If you still
see it, I may need to look at your setup to see what it is that
we are doing differently.
Comment 4 Bryan Che 2004-01-19 12:51:42 EST
Discovered after more investigation that this problem is due to my
custom com.arsdigita.runtime.Startup.java file, which was forcing a
certain ordering for initializers in Oracle.  After reverting to the
standard Startup.java file, this problem went away.  So, the root of
the problem was bugzilla 113324, which is now listed as qa_ready.

Note You need to log in before you can comment on or make changes to this bug.