Bug 113749 - epiphany does not run
epiphany does not run
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: epiphany (Show other bugs)
1
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Marco Pesenti Gritti
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-16 21:50 EST by Chuck Mead
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-11 10:45:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chuck Mead 2004-01-16 21:50:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
I am running FC1 on an x86_64 and epiphany does not run.

csm@stealth SRPMS]$ rpm -q epiphany
epiphany-1.0.4-2

[csm@stealth SRPMS]$ epiphany
Cannot find mozilla installation directory. Please set
MOZILLA_FIVE_HOME to your mozilla directory
[csm@stealth SRPMS]$ export MOZILLA_FIVE_HOME=/usr/lib/mozilla-1.4.1/
[csm@stealth SRPMS]$ epiphany
/usr/bin/epiphany-bin: error while loading shared libraries:
libgtkembedmoz.so: cannot open shared object file: No such file or
directory

[csm@stealth SRPMS]$ locate libgtkembedmoz.so
/usr/lib/mozilla-1.4.1/libgtkembedmoz.so

So then I snagged the src.rpm of epiphany and tried to rebuild it and
I get this:

checking for mozilla-gtkmozembed... Package mozilla-gtkmozembed was
not found in the pkg-config search path.
Perhaps you should add the directory containing `mozilla-gtkmozembed.pc'
to the PKG_CONFIG_PATH environment variable
No package 'mozilla-gtkmozembed' found
 
configure: error: Library requirements (mozilla-gtkmozembed) not met;
consider adjusting the PKG_CONFIG_PATH environment variable if your
libraries are in a nonstandard prefix so pkg-config can find them.
error: Bad exit status from /var/tmp/rpm-tmp.33006 (%build)
 
 
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.33006 (%build)



Version-Release number of selected component (if applicable):
epiphany-1.0.4-2


How reproducible:
Always

Steps to Reproduce:
1.type "epiphany" at the command line
2.
3.
    

Actual Results:  The system out this error: Cannot find mozilla
installation directory. Please set MOZILLA_FIVE_HOME to your mozilla
directory

Expected Results:  epiphany should have run.

Additional info:

See the description field.
Comment 1 Justin M. Forbes 2004-01-18 10:21:24 EST
This is because 64bit mozilla is not installed, and epiphany requires
it.  Will figure out something before release.
Comment 2 Marco Pesenti Gritti 2004-10-11 10:45:57 EDT
64 bit mozilla is installed in Fc2. I assume this is working now.

Note You need to log in before you can comment on or make changes to this bug.