Bug 113817 - ntsysv looks in rc0.d with 2.6 kernel
Summary: ntsysv looks in rc0.d with 2.6 kernel
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: chkconfig (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-18 21:03 UTC by Behdad Esfahbod
Modified: 2014-03-17 02:41 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-28 14:39:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Behdad Esfahbod 2004-01-18 21:03:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114 Epiphany/1.0.4

Description of problem:
ntsysv used to work.  Now that I'm running 2.6.1-1.43 kernel from
rawhide, when I run ntsysv, it shows me all non-xinetd services off. 
Running with strace I see that it's looking into /etc/rc.d/rc0.d/

chkconfig works as it's expected.

system-config-services generates python errors and refuses to run so I
cannot check that one.

Version-Release number of selected component (if applicable):
ntsysv-1.3.9-1

How reproducible:
Always

Steps to Reproduce:
1. Boot with 2.6 kernel from rawhide
2. Run ntsysv
3.
    

Actual Results:  All non-xinetd services are off

Expected Results:  Some services should be on

Additional info:

Comment 1 Bill Nottingham 2004-01-19 06:19:24 UTC
What's the output of the 'runlevel' command?

Comment 2 Behdad Esfahbod 2004-01-19 06:21:33 UTC
[root@mces root]# runlevel
unknown


Comment 3 Behdad Esfahbod 2004-01-19 06:23:19 UTC
Sorry Bill, seems to be a problem from my side.  I've got no
/var/run/utmp nor /var/run/wtmp.  Don't know why.  Just that 'strace
runlevel' shows that it looks for them.

Do you have any idea how they can disappear?  I'm sure ntsysv was working.

Comment 4 Bill Nottingham 2004-01-19 06:28:12 UTC
Not off the top of my head. I'd do the obvious checks for
trojans/compromises.

Comment 5 Behdad Esfahbod 2004-01-19 06:36:48 UTC
Well, actually a second check shows that I've got a healthy
/var/log/wtmp, so last(1) works.  What runlevel is looking for and I
don't have is /var/run/utmpx and /var/run/utmp.

So, you know how runlevel is supposed to work.

Comment 6 Behdad Esfahbod 2004-01-28 14:39:36 UTC
Apparently this has been a minor problem in my side.  Now I see there
is a /var/run/utml and runlevel works fine.  Closing.


Note You need to log in before you can comment on or make changes to this bug.