Bug 11387 - DPT SCSI module problem - cannot mount SCSI CD-ROM
Summary: DPT SCSI module problem - cannot mount SCSI CD-ROM
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alan Cox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-12 15:29 UTC by leg22
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-08 21:22:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description leg22 2000-05-12 15:29:15 UTC
The following bug was observed on a system with the following relevant
hardware specifications:

Pentium III (450 MHz clock)
128 Mb PC100 SDRAM
PCCHIPS M750 motherboard
Maxtor 8 Gb ATA hard drive
TEAC CD516-CS SCSI CD-ROM
DPT PM2024 SCSI-2 card

The system was initially set up with RedHat Linux 6.1 to boot off the
Maxtor hard drive (the kernel used was 2.2.12-??). The appropriate SCSI
kernel module (eata_dma) was configured properly, and the CD-ROM worked
without issue. The system was later upgraded to RedHat 6.2. After the
upgrade, the SCSI card would initialize properly (i.e., the module would
load without issue), but any attempt to mount the CD-ROM (via /dev/scd0)
would cause the mount process to freeze and go into deep kernel sleep.
Some change between kernel versions 2.2.12 and 2.2.14 appears to be causing
this problem, as the CD-ROM still works if the system is booted up into a
2.0.33-based Linux distribution (called tomsrtbt). The following items were
observed via dmesg after attempting to mount the CD-ROM while in RedHat
6.2:

scsi0 channel 0 : resetting for second half of retries.
SCSI bus is being reset for host 0 channel 0.
eata_reset called pid:9 target: 1 lun: 0 reason 0
eata_reset: board reset done, enabling interrupts.
eata_reset: interrupts disabled again.
eata_reset: exit, wakeup.
scsi0 channel 0 : resetting for second half of retries.
SCSI bus is being reset for host 0 channel 0.
eata_reset called pid:11 target: 1 lun: 0 reason 0
eata_reset: slot 20 in reset, pid 11.
eata_reset: board reset done, enabling interrupts.
eata_reset: interrupts disabled again.
eata_reset: slot 20 locked, DID_RESET, pid 11 done.
scsi0: device driver called scsi_done() for a syncronous reset.
eata_reset: exit, pending.
eata_dma: int_handler, reseted command pid 11 returned
VFS: Disk change detected on device sr(11,0)

Comment 1 Alan Cox 2000-08-08 21:22:00 UTC
Does the 'eata.o' driver work for you >


Comment 2 leg22 2000-08-09 15:05:59 UTC
Yes; it turns out that the eata_dma.o module is deprecated; the eata.o
works with the DPT PM2024. I do recall that the former was originally
recommended for use with this SCSI card, so I may have been mislead by erroneous
manual information somewhere.


Note You need to log in before you can comment on or make changes to this bug.