Bug 113902 - Calendar only remembers 1 event
Summary: Calendar only remembers 1 event
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: squirrelmail   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Gary Benson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-20 00:19 UTC by Phil Anderson
Modified: 2007-04-18 17:01 UTC (History)
0 users

Fixed In Version: 1.4.2-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-21 12:07:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Phil Anderson 2004-01-20 00:19:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
Since upgrading from 1.4.0 to 1.4.2, the calendar will only remember
the last item entered.

Version-Release number of selected component (if applicable):
1.4.2

How reproducible:
Always

Steps to Reproduce:
1. Turn on the calendar plugin
2. Enter 1 event
3. Enter another event

    

Actual Results:  Only the latest event is recorded

Expected Results:  Both events should exist

Additional info:

Downgrading to 1.4.0 fixes the problem.  A bug has been reported
upstream.  I'll try to take a look at this tonight and hopefully post
a fix within a day or two.  The bug doesn't appear to be happening on
a couple of friend's sites, so it is possibly specific to Fedora's
version of PHP.

Comment 1 Phil Anderson 2004-01-21 00:46:44 UTC
Note that by upgrading to 1.4.2, users will LOOSE ALL EXISTING DATA
without warning when they add their first new event after an upgrade.
 ( Stupid me thinking that I only needed to backup /home )

This is a known issue in Squirrelmail 1.4.2.  They suggest using the
calendar plugin from 1.4.1 or 1.4.3CVS.

Here is the thread with a patch to fix the problem.
http://sourceforge.net/mailarchive/message.php?msg_id=6313020





Comment 2 Gary Benson 2004-01-21 12:07:28 UTC
Thank you for your efforts. I've applied the patch and built a new
package, so it should work now.


Note You need to log in before you can comment on or make changes to this bug.