Bug 113906 - Bad: g++: Internal error: Segmentation fault
Bad: g++: Internal error: Segmentation fault
Status: CLOSED DUPLICATE of bug 110244
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-19 19:45 EST by Larry Creech
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Larry Creech 2004-01-19 19:45:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
The package lufs from sourceforge crashes g++ on fedora-core:

http://sourceforge.net/project/showfiles.php?group_id=57332

g++ -DHAVE_CONFIG_H -I. -I. -I../.. -I../
-I/usr/src/lufs-0.9.6/include -O2 -Wall -DSSHPROG=\"/usr/bin/ssh\" -MT
sshfs.lo -MD -MP -MF .deps/sshfs.Tpo -c sshfs.cpp  -fPIC -DPIC -o sshfs.lo
g++: Internal error: Segmentation fault (program cc1plus)
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
make[3]: *** [sshfs.lo] Error 1
make[3]: Leaving directory `/usr/src/lufs-0.9.6/filesystems/sshfs'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/src/lufs-0.9.6/filesystems'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/lufs-0.9.6'
make: *** [all] Error 2


Version-Release number of selected component (if applicable):
gcc-3.3.2-1

How reproducible:
Always

Steps to Reproduce:
1.download lufs from
http://sourceforge.net/project/showfiles.php?group_id=57332
2. Unpack it, ./configure and make. 
3. 
    

Actual Results:  g++ -DHAVE_CONFIG_H -I. -I. -I../.. -I../
-I/usr/src/lufs-0.9.6/include -O2 -Wall -DSSHPROG=\"/usr/bin/ssh\" -MT
sshfs.lo -MD -MP -MF .deps/sshfs.Tpo -c sshfs.cpp  -fPIC -DPIC -o sshfs.lo
g++: Internal error: Segmentation fault (program cc1plus)
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
make[3]: *** [sshfs.lo] Error 1


Expected Results:  Expected it to compile.

Additional info:
Comment 1 Richard Henderson 2004-10-04 04:31:00 EDT

*** This bug has been marked as a duplicate of 110244 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:00:50 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.