This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 113913 - iiimf-* packages should obsolete im-sdk
iiimf-* packages should obsolete im-sdk
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: im-sdk (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Yu Shao
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-19 21:16 EST by Jens Petersen
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-04 15:52:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2004-01-19 21:16:28 EST
Description of problem:
When trying to upgrade from the jumbo im-sdk package to the new
iiimf-* packages, many file conflicts arise because the new
packages do not obsolete im-sdk.

Version-Release number of selected component (if applicable):
im-sdk-11_4-4

How reproducible:
every time

Steps to Reproduce:
1. install im-sdk-11_4-1
2. upgrade to im-sdk-11_4-4
  
Actual results:
        file /usr/lib/im/include/iiimp-data.h from install of
iiimf-protocol-lib-devel-11_4-4 conflicts with file from package
im-sdk-11_4-1
        file /usr/lib/im/include/iiimp.h from install of
iiimf-protocol-lib-devel-11_4-4 conflicts with file from package
im-sdk-11_4-1
        file /usr/lib/im/lib/libiiimp.a from install of
iiimf-protocol-lib-devel-11_4-4 conflicts with file from package
im-sdk-11_4-1
        file /usr/lib/im/lib/libiiimp.la from install of
iiimf-protocol-lib-devel-11_4-4 conflicts with file from package
im-sdk-11_4-1
        file /usr/lib/im/lib/libiiimp.so.0.0.3 from install of
iiimf-protocol-lib-devel-11_4-4 conflicts with file from package
im-sdk-11_4-1
        file /usr/lib/im/lib/libEIMIL.a from install of
iiimf-protocol-lib-11_4-4 conflicts with file from package im-sdk-11_4-1
        file /usr/lib/im/lib/libEIMIL.la from install of
iiimf-protocol-lib-11_4-4 conflicts with file from package im-sdk-11_4-1
:
:

Expected results:
No errors - the iiimf-* packages should obsolete im-sdk.
Comment 1 Yu Shao 2004-02-04 15:52:01 EST
Will be fixed in 11.4-6.

Note You need to log in before you can comment on or make changes to this bug.