Bug 113930 - (NET ORINOCO) Hermes/Orinoco driver dies under heavy load
(NET ORINOCO) Hermes/Orinoco driver dies under heavy load
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-20 05:00 EST by Matthew Booth
Modified: 2013-07-02 22:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:31:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Booth 2004-01-20 05:00:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031026 Firebird/0.7

Description of problem:
I have a linksys Prism 2 based 802.11b wireless card. Under very heavy
load I get the following output in /var/log/messages:

Jan 20 09:34:27 gideon kernel: wlan0: Error -110 writing Tx descriptor
to BAP
Jan 20 09:34:27 gideon last message repeated 219 times
Jan 20 09:34:27 gideon kernel: hermes @ MEM 0xf8ab1000: Timeout
waiting for command completion.
Jan 20 09:34:27 gideon kernel: hermes @ MEM 0xf8ab1000: Error -16
issuing command.
Jan 20 09:34:27 gideon kernel: wlan0: Error -110 writing Tx descriptor
to BAP
Jan 20 09:34:27 gideon kernel: hermes @ MEM 0xf8ab1000: Error -16
issuing command.
Jan 20 09:34:27 gideon kernel: hermes @ MEM 0xf8ab1000: Error -16
issuing command.
Jan 20 09:34:27 gideon kernel: wlan0: Error -110 writing Tx descriptor
to BAP
Jan 20 09:34:29 gideon last message repeated 1891 times
Jan 20 09:34:29 gideon kernel: hermes @ MEM 0xf8ab1000: Error -16
issuing command.
Jan 20 09:34:29 gideon kernel: hermes @ MEM 0xf8ab1000: Error -16
issuing command.
Jan 20 09:34:29 gideon kernel: wlan0: Error -110 writing Tx descriptor
to BAP
Jan 20 09:34:29 gideon kernel: hermes @ MEM 0xf8ab1000: Error -16
issuing command.

I immediately lose network when this happens. I am using the
orinoco/orinoco_pci drivers.

When the machine gets into this state it does not hang immediately. I
can do 'ifdown wlan0'. However 'rmmod orinoco_pci orinoco hermes' will
normally cause the machine to become unresponsive. When it hasn't,
'ifup wlan0' always has.

Version-Release number of selected component (if applicable):
kernel-smp-2.4.21-9.EL

How reproducible:
Sometimes

Steps to Reproduce:
1. Initiate a transfer which maxes the wireless link for a while (eg
copying an iso to my mailserver).
2. Do anything else with the network at the same time.

This crashes every time for me, but the amount of time it takes
varies. It doesn't seem to crash until Step 2. 1 on its own doesn't
seem enough.

Actual Results:  Machine loses network, logs fill up with error
messages. Any attempt to restart the network causes the entire system
to hang.

Expected Results:  Files copy at maximum possible speed.

Additional info:

From lsmod:

orinoco_pci             4420   1
orinoco                41484   0  [orinoco_pci]
hermes                  8228   0  [orinoco_pci orinoco]

From lspci:

02:0a.0 Network controller: Harris Semiconductor Prism 2.5 Wavelan
chipset (rev 01)

Machine is single i686 with hyperthreading enabled, running smp kernel.
Comment 1 Matthew Booth 2004-01-20 13:26:54 EST
This problem seems to be authoritatively discussed by the driver
maintainer here:

http://ozlabs.org/people/dgibson/dldwd/

about half way down, under the driver list.
Comment 2 Suzanne Hillman 2004-02-26 15:06:57 EST
Mmm. At least from what I can tell by looking at hardware.redhat.com,
we don't support linksys anything. So is this a feature request - to
try to get us to support it?
Comment 3 Suzanne Hillman 2004-02-26 15:12:15 EST
Mmm. I meant it's not certified for RHEL... not sure about support.
Comment 5 Mace Moneta 2005-07-30 00:09:19 EDT
This appears to be corrected by the
linux-2.6.12-net-make-orinoco-suck-less.patch in FC3.  After applying kernel
kernel-2.6.12-1.1372_FC3, this problem no longer occurs, and the Orinoco driver
has been rock solid for me (with the same card as the original reporter).  
Comment 6 RHEL Product and Program Management 2007-10-19 15:31:05 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.