Bug 113947 - rhn_check fails to update client
rhn_check fails to update client
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Adrian Likins
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-20 10:45 EST by Christopher Basquez
Modified: 2009-11-13 11:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-13 11:07:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Terry Jones 2004-01-20 10:45:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1)
Gecko/20030225

Description of problem:
rhn_check silently fails when it runs on a client that has been
registered using activation keys and has never used up2date.

This came to light when we were using kickstart to install the OS and
register the client. The client would then never accept updates.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Provision a client with OS (note client is registered with
satellite using activation key)
2. Schedule updates
3. run rhn_check on client
    

Actual Results:  The update fails stating that the RH gpg key is not
installed on the client - note this error is on the satellite.

Expected Results:  The scheduled packages should have been downloaded.

Additional info:

rhn_check does not install the RH gpg key if it is not already
installed. This should be the default since the above method -
provision, register with activation key, schedule updates - is the
method we are pushing with customers.
Comment 1 Bret McMillan 2004-01-20 10:51:39 EST
This is an rhn_check / up2date bug, sounds like.
Comment 2 Adrian Likins 2004-01-20 15:09:17 EST
you didnt include any version info, but I assume this
is for RHEL2.1?
Comment 3 Terry Jones 2004-01-20 15:11:35 EST
Sorry about that - yes this is with the 2.1 version of satellite.
Comment 4 Adrian Likins 2004-01-20 17:37:38 EST
hmm, 2.1AS-u3 should automatically have the RH gpg keys
already added to the keyring (/etc/sysconfig/rhn/up2date-keyring.gpg)

what versions of rhn_register/up2date are you seeing
this with?
Comment 5 Terry Jones 2004-01-20 22:19:00 EST
The CLIENTS we were installing were RHEL WS3.

I don't have them to hand but can find out the up2date (no
rhn_register) version if necssary but they should be whatever comes on
the WS3 install disks.
Comment 6 Adrian Likins 2004-09-02 12:19:59 EDT
I belive this is fixed in more recent U3 releases, setting
to modified to have QA verify this.

Note You need to log in before you can comment on or make changes to this bug.