Bug 113957 - Segmentation fault when querying interface with ethtool
Segmentation fault when querying interface with ethtool
Status: CLOSED DUPLICATE of bug 112722
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: ethtool (Show other bugs)
2.1
i686 Linux
low Severity low
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-20 12:16 EST by Jason Martens
Modified: 2013-07-02 22:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Martens 2004-01-20 12:16:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031110 Firebird/0.7

Description of problem:
When querying a network interface using ethtool, the query is
successful but causes a segmemtation fault at the end of the outupt. 
The output looks like this:

[root@server root]# ethtool eth0
Settings for eth0:
        Supported ports: [ MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Advertised auto-negotiation: Yes
        Speed: 100Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 1
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: g
        Wake-on: d
        Current message level: 0x000000ff (255)
        Link detected: yes
Segmentation fault
[root@server root]#

Version-Release number of selected component (if applicable):
ethtool-1.8-0.2

How reproducible:
Always

Steps to Reproduce:
1. Same as above.
    

Actual Results:  No negative side effects have been observed.

Expected Results:  ethtool should not cause a segmentation fault

Additional info:

uname -a 
Linux server 2.4.9-e.35smp #1 SMP Tue Dec 23 00:15:55 EST 2003 i686
unknown

Dell Poweredge 2650 using tg3 network driver
Comment 1 Suzanne Hillman 2004-02-04 13:16:29 EST

*** This bug has been marked as a duplicate of 112722 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:00:51 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.